Updating issues with GO5100 / Win10 — TomTom Community

Updating issues with GO5100 / Win10

Hi,
When trying to update, my 5100 loses connection to MyDrive after 4-5 seconds, device says "Keep your device connected, The update will resume in a few moments", but I don't see any progress. Download continues in the background, so when I disconnect/reconnect the 5100, the download has progresses a few percent.
In addition, I have the "No maps available" but since the connenction is interrupted after such short time, I cannot even get to the map section of "My Products". I am on Windows 10 version 2004 Build 19041.21. I have a second 5100 under a different login which updated without problems yesterday.
I left it physically connected over night, but nothing happened in the time when the downloaded updated should have installed.

Ernst / Mullern88

P.S. I should add that I have tried all other W10 related suggestions multiple times. I have used the method of changeing the Registry of W10, which worked very well for a long time. Now, the W10 registry "trick" seems not to work anymore. .

Comments

  • YamFazManYamFazMan Posts: 18,413
    Superusers
    edited January 2020
    Hi
    @mullern88
    mullern88 wrote: »
    P.S. I should add that I have tried all other W10 related suggestions multiple times. I have used the method of changeing the Registry of W10, which worked very well for a long time. Now, the W10 registry "trick" seems not to work anymore. .
    The Hack is working here on My Linx 10/10 Win10 Tablet
    ________________________________

    Re "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"

    Win7 See... http://www.sevenforums.com/tutorials/147369-usb-selective-suspend-turn-off.html

    Win10 See… https://www.tenforums.com/tutorials/73187-turn-off-usb-selective-suspend-windows-10-a.html
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Also turn off any Screen savers any other Power savers or USB port monitoring software installed
    ________________________________

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work

    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu... You will need to edit the Registry before the USB Selective Suspend menu will display (See Note... (4) below)

    Laptop users also see Note (1) (2) & (3)
    Note... (1) My Linx 10/10 Win10 Tablet is exactly the same... I had to edit the Registry to activate the advanced setting in the Power Menu

    Note...(2) Recently a User with a Dell XPS 9360 Laptop also exactly the same problem ... he also had to edit the Registry to activate the advanced setting in the Power Menu

    (Edit) Note... (3) Thanks User 333... Just had a similar problem with new Dell XPS 13 7390 (running Windows 10) which only comes with USB-C port. Found that I was able to update my TomTom Via 225 (using a supplied USB-C to USB-3 cable/hub) only after changing this setting in Windows 10:
    Settings - Device - USB - Un-tick this box: Stop devices when my screen is off to help save battery. If you're having problems with connected devices, clear the check-box.

    Note... (4) Editing the Registry... https://discussions.tomtom.com/en/discussion/comment/1234855/#Comment_1234855

    ATB YFM
  • mullern88mullern88 Posts: 6 [Apprentice Traveler]
    Thanks for the tips, YFM. Unfortunately, non of them is working. The USB Power option is not available anymore in the "Advanced Power Settings".

    9hsazdrkgcfj.png

    I do however have the "CsEnabled" in the Reg on "0", and of course restarted after the reg Change I also followed the other tips in your post for Surface Dock (I have) but no success. The GO5100 is still disconnecting after about 5 seconds.

    Any other ideas? Thankful for suggestions.
    Ernst / Mullern88
  • VikramKVikramK Posts: 10,897 Moderator
    Hi @mullern88

    I asked our 2nd Line team to review the download logs for your device.

    Looks like the map update process gets stuck due to connectivity issues. In most cases, this is related to an interrupted connection.

    • Aggressive anti-virus / firewalls.
    • Poor wi-fi connection and internet speed.
    • ISP (Internet Service Provider) or router issues. This also includes office and business networks.

    It’s highly recommended that you read the advice provided on the FAQ here: https://uk.support.tomtom.com/app/answers/detail/a_id/3611

    Over here it’s highly recommended that you use a fast internet connection along with configured Anti-Virus and firewall on the computers. Avoid installing updates by clicking on 'Update all" instead use the My Content tab and install one update at a time..

    If the above does not work then I would advise that you try on a different computer with a different internet connection.

    Regards
    Vikram
  • mullern88mullern88 Posts: 6 [Apprentice Traveler]
    Thanks for these, Vikram. Unfortunately, the tips do not help. I am on a LAN connection, my provider is very reliable, and the problem is NOT an interrupted download due to network issues. I have used the same procedure two days ago with a second 5100 I own (different account).

    If I connect the GO5100 here in question with the USB (and I use the same cable for several years and for both devices) the 5100 connects, and I get the connected message in MyDrive. WITHOUT DOING ANYTHING, the 5100 disconnects after few seconds. The Map Updates downloaded independently to my computer, and apparently, in a moment, the map update started when the 5100 was connected a bit longer than 5-6 seconds from the downloaded file.

    I have been using this procedure for many years and have been struggling hard with all the issues in MyConnect related to Win10. Tomtom knows perfectly well for many years that WIN10 and MyDrive don't really go together, and that the USB driver for the GO products is suboptimal.

    As a former IBM employee (System Engineering) and later IT Manager in a KMU I am pretty well able to analyse problems and do an evaluation of possible reasons. My network for sure is it not. The loss of USB connection of the GO5100 for sure is. Amm my other USB connected devices do not have any problems, and a have many of them, and not only USB sticks.

    I would be extremely grateful for getting my 5100 to work without problems. Thanks for any suggestion.
    Ernst / Mullern88
  • YamFazManYamFazMan Posts: 18,413
    Superusers
    edited January 2020
    Hi
    @mullern88

    It's strange... The Hack is working here on My Linx 10/10 Win10 Tablet....

    y8lo1r2k68db.jpg
    ATB YFM
  • mullern88mullern88 Posts: 6 [Apprentice Traveler]
    Hi YMF

    you reply inspired me to start a further search on ths issue. And I found something I need to try when I have a few hours to sit.

    Have a look at
    https://www.tenforums.com/tutorials/100643-remove-usb-selective-suspend-setting-power-options-windows.html

    This link is accessed from
    https://www.tenforums.com/general-support/142867-missing-advanced-power-options.html

    where you find the whole discjussion about Advanced Power Options missing, It looks as if MS has changes quite a lot in the registry. Note that I am on W10 Version 2004 already. I will report when I have results.

    Thanks and regards
    Ernst / Mullern 88
  • mullern88mullern88 Posts: 6 [Apprentice Traveler]
    Good day,

    I have changed registry (CsEnabled to "0", made USB Power Options visible in Power Plan settings and disabled the two settings) as per the information mentioned above), unfortunately no change. The GO5100 still disconnects after a few seconds, so that an update is not possible, neither the updates, nor the repair of the broken map.

    If I don't get it back to work within the next week I will throw it and change brand.
    Thanks for support and regards, enjoy Sunday.
    Ernst / Mullern88
  • Creg1955Creg1955 Posts: 1 [New Seeker]
    I have no real expertise to offer but 'Csenabled' is not available on my W10 laptop via Regedit, but I was able to access the USB control via the advanced power options on my Power Plan.
    This next piece of info may be obvious to more expert users, but by stopping my VPN (NordVPN) I was able to make progress with my download. When I put it on again the download stopped again.
Sign In or Register to comment.

Who's Online in this Category0