Tomtom 5100 not working — TomTom Community

Tomtom 5100 not working

Hi, My last sat nav was a Garmin so I am not sure if i have a faulty tomtom or that i am missing something. My 5100 connects to tomtom services, shows gprs connected, is fully updated via MyDrive, the arrowing representing my car/position is placed on the road just outside my house but it doesn't move. I have drove around the block a few times but the arrow stays in the same place. the only time i see it move is after a reset. It starts at London and moves to the road outside my house a minute or two after reset.

Answers

  • VikramKVikramK Posts: 8,832 TomTom Moderator
    Hi @khiz

    Welcome to the community!

    To ensure good satellite reception, use your GO outdoors and keep it upright. Large objects such as tall buildings can sometimes interfere with reception.

    Below is a FAQ link to troubleshoot any GPS related issues-

    https://uk.support.tomtom.com/app/answers/detail/a_id/16092

    Regards
    Vikram
  • khizkhiz Posts: 2 [New Seeker]
    Hi @VikramK , Thank you for replying. I stuck my TomTom outside my attic window for over 2 hours, plugged in, upright and switched on with a clear view of the sky. I reset it, powered it on and off a few times, set different routes. The arrow is still greyed out.
    I am running out of ideas.
  • VikramKVikramK Posts: 8,832 TomTom Moderator
    Hi @khiz

    Thanks for trying out the suggestions.

    It sounds like the satellite signal reception issue. Could you report this to the customer service, please?

    Regards
    Vikram
Sign In or Register to comment.

Who's Online in this Category0