TomTom Go 40 is stuck on select country. How do I move past this? — TomTom Community

TomTom Go 40 is stuck on select country. How do I move past this?

TFS2112TFS2112 Posts: 7 [Apprentice Seeker]
TomTom Go 40 is stuck on select country. I have read the previous answers. I have connected to MyDrive Connect. It states that updates have been updated. Green check tick is shown

Best Answer

Answers

  • butch 72butch 72 Posts: 2 [Apprentice Traveler]
    i just had same problem on the 22/12 2019 and couldnot find any help as it was holidays but i did find a community suggestion that said to reset device to factory setting also i would save any of your important information to put back into device when it has cleared problem.
  • TFS2112TFS2112 Posts: 7 [Apprentice Seeker]
    Thank you. I just tried the reset and sat nav comes back to the same page.
  • DougLapDougLap Posts: 8,889
    Superuser
    edited January 2020 Accepted Answer
    Hi @TFS2112

    This can happen if you have no map on your device. Have a look in MDC and see if you can install a map. Have you got an extra memory card installed.

    See here

    https://discussions.tomtom.com/en/discussion/comment/1644346/#Comment_1644346

    Doug
  • TFS2112TFS2112 Posts: 7 [Apprentice Seeker]
    Hi DougLap,
    Thanks for the link. Sorry to be a pain.
    I don't have an SD card, will purchase one.
    I went into mydrive connect to look for maps for my device. No maps there. I went to update maps where I can purchase maps or update maps. I went to update maps, kept going through same loop of installing my mydrive connect.
    I only require a UK map. Sorry for being a bit dull.
  • YamFazManYamFazMan Posts: 20,088
    Superusers
    edited January 2020
    Hi
    @TFS2112

    Scroll down the MyDrive Connect Map install screen you may be offered various special Map cut to fit the 8GB Memory of your device....
    See... https://discussions.tomtom.com/en/discussion/comment/1660206/#Comment_1660206

    ATB YFM
  • VikramKVikramK Posts: 12,721 Moderator
    Hi @TFS2112

    There was some issue with activation of services on your GO 40 device.

    The team has made some changes in the backend, I would recommend that you do a soft reset, connect the device to MyDrive Connect and check for updates.

    Regards
    Vikram :)
  • TFS2112TFS2112 Posts: 7 [Apprentice Seeker]
    Thank you everyone. I will go through the advice again.
    My elderly father is borrowing my Sat Nav as his appointments have changed to areas he hasn't been to and he is panicking. It will help him to be independent again once we get the Nav to work. And I am not a tech person at all - hopefully with your good advice we can sort it!
    Many thanks in advance.
    Will keep you posted .
  • TFS2112TFS2112 Posts: 7 [Apprentice Seeker]
    Hi Vikram,

    I did a soft reset.
    Connected my device to Mydrive.
    Stated on my laptop: your device is up to date.
    There was a green tick on my Sat Nav.
    On laptop, I went into my content.
    There are products to purchase (sat nav and maps).

    Two days ago 'my voices' and 'traffic lifetime update' were available and now it's just 'my voices'.

    My Voices is in My contents. I tried to install 'Daniel' just before 3.00pm and it was still showing as ready to go at 3.30pm. Seemed to be stuck.

    My sat nav is still stuck on ', choose a country'.

    I have gone through as much possible the advice provided regarding maps but if the 'maps' isn't available in 'my content' apart from purchasing it, I am unable to move forward.

    I have gone through the soft reset a few times, followed the instructions.

    I have deleted and reinstalled myDrive connect.
    In the final reset in 'my products' it states: we could not find any installed service for your device

    I don't know what to do.

    Am I missing an instruction?
  • VikramKVikramK Posts: 12,721 Moderator
    edited January 2020
    Hi @TFS2112

    For some strange reason, the services are associated with the device but not active.

    I have activated the map which should be offered for download now.

    For the rest of the services, could you login to the device using your TomTom account? Make sure the device is connected to TomTom Services using a smartphone.



    Regards
    Vikram
  • TFS2112TFS2112 Posts: 7 [Apprentice Seeker]
    Hi Vikram,
    I have logged into My Drive Connect on laptop.

    Connected device to SatNav.
    Done a soft reset on SatNav.
    Seems to be stuck on the system information page whereas before I would have the 'choose language' option or an updated prompt with green check mark.
    hohqn2zghp89.jpg.

    I have disconnected SatNav from laptop, did a soft reset. Still showing system information.

    On laptop in 'my content' I can see 20 updates available which are the maps. Thank you for those.

    'my updates and new items' - Clicked on United Kingdom and Republic of Ireland.
    Unable to tick box.

    Scrolled down the page to 'My Maps'.
    Clicked onto the same map.
    Install box is light. I have clicked on it. No response.
    States 'connect your device' when I hover over 'install'.
    My device is connected to laptop but still showing system information page.

    Scrolled down again to 'My Services'.
    Clicked on same map.
    Comes up these:
    Go to shop
    Manage your map.

    Therefore unable to install the updated map on lifetime map services.

    Also my unable to connect to my device via smartphone due to not being able to move on from the system information page.

    So close, yet so far!

    Do you think the device has reached end of its lifeline?

    Kindest of regards,
    TFS2112

  • VikramKVikramK Posts: 12,721 Moderator
    Hi @TFS2112

    That screen usually comes up when you press and hold the on/off button for a prolonged period of time.

    Could you please get in touch with our customer service, I think trying the troubleshooting advice over the phone can help.

    Regards
    Vikram
Sign In or Register to comment.

Who's Online in this Category0