Address search not working properly — TomTom Community

Address search not working properly

G0 620 wifi. This is my 3rd Tomtom. My new Go 620 does not seem to recognize the numbers I enter in the address search. The search suggestions all appear to be cities and towns because it doesn't see the digits I enter in the search bar.

Best Answer

Answers

  • DougLapDougLap Posts: 4,009 Superuser
    Hi @boost

    What numbers are you entering. Are they Long /Lat if so then do the following

    Tap menu
    Tap Search
    Tap Whole World or Map (top Right of screen)
    Scroll down and select Long/Lat.
    Enter figures in one of the format versions shown on the device.
    The example figures shown are your current position if the device has locked onto the sats.

    Doug
  • boostboost Posts: 17 [Master Explorer]
    Here is an address I tried. 1850 Matheson Blvd. See picture for results.

    https://i.imgur.com/Ks4tB5I.jpgadh58lk592r0.jpg
  • boostboost Posts: 17 [Master Explorer]
    Here is another search.

    k7yfj9k226f7.jpg
  • boostboost Posts: 17 [Master Explorer]
    Thank you, thank you, thank you.
    I had never seen that setting before on my previous Tomtoms.
    I thought I had a defective unit and was preparing to ship it back.
  • DougLapDougLap Posts: 4,009 Superuser
    Hi @boost

    Your welcome.

    Doug
  • boostboost Posts: 17 [Master Explorer]
    ut5uttxnvn49.gif

    3eq4i2pjefmb.gif


    Next question is about BT connection.

    Have you seen this before? It has been doing this for 5 minutes.

    I turned the bt off and then on at the phone, no change.
    Then I restarted the Tom (10 secs button) until I heard the drums. After that the bt connected properly.
    I really hope is doesn't do this again because I can't be doing this while driving.
  • DougLapDougLap Posts: 4,009 Superuser
    edited December 2019
    Hi @boost

    I assume you have an Apple Phone running IOS13. This situation started with the introduction of IOS13 and has not been resolved yet by Apple or Tomtom. I assume you also have the TomTom MyDrive App open on the phone as that is a requirement as well.

    If you have an old Apple phone running IOS 12 you will find that will work with the TT unit perfectly. TT have said they have been and continue you to watchi the updates of iOS 13 being issued by Apple to sort out Bugs and will issue an update of the My Drive App when a suitable solution is found.

    You can try not connecting via Bluetooth but use the Phone as a hotspot and see if that resolves the problem in the meantime. By the way the Traffic data option that is struggling to connect will not work when within range of your Wifi.

    Doug
  • boostboost Posts: 17 [Master Explorer]
    Sorry, I should have told you that I am using a Moto G7 Play android.
    I'll see how it functions this week as I will be using it to get to work and home.
  • DougLapDougLap Posts: 4,009 Superuser
    edited December 2019
  • boostboost Posts: 17 [Master Explorer]
    Thanks again
Sign In or Register to comment.

Who's Online in this Category0