Why will my Tomtom Go 6000 not connect? — TomTom Community

Why will my Tomtom Go 6000 not connect?

Celine125Celine125 Posts: 6 [Master Explorer]
I have just reinstalled MyDrive on a Windows 10 laptop but the TomTom is displaying an error screen which indicates that the device is not connected to the laptop. I have tried several USB ports and a different cable but with the same result. I've tried disconnecting and switching off and on - same result. I get the TomTom start noise, then the loading icon, then the error screen. The laptop says it's downloading updates, then that the device isn't connected. Sometimes it says the server is busy. WTF?

Comments

  • Celine125Celine125 Posts: 6 [Master Explorer]
    edited December 2019
    I have tried updating the driver, uninstalling and reinstalling the software and everything else I can think of. The driver appears to be correctly installed and is the latest version. Windows is reporting "Device USB\VID_(serial no.) requires further installation."
  • Celine125Celine125 Posts: 6 [Master Explorer]
    Digging further, the 'further installation' message is a red herring, as it related to the first message, not the most recent. The driver is installed 'correctly' but refuses to function. So either the driver is incompatible with the latest version of Windows 10 or there is some other software issue with the TomTom. It is definitely getting power from the cable and can be seen from the PC, as it is trying to connect, but each time the full handshake is failing.
  • paultrademarkpaultrademark Posts: 2 [Apprentice Traveler]
    Getting very similar issue with my Go 6000, when I installed MyDrive connect on my new Windows 10 laptop.
    Had various issues, saying no internet connection when there was, not connected, and when does connect it kicks it off during an update.
  • DougLapDougLap Posts: 7,171
    Superuser
    Hi @paultrademark

    Lots of the current PC's have power settings that turn the USB sockets off as a method of helping get a long battery life. Have a look at the power settings to see if you can turn them off and then see if that helps.

    Doug
  • Celine125Celine125 Posts: 6 [Master Explorer]
    Thanks for the suggestion, Doug, but in my case it's definitely not the USB socket. This is happening on all 3 sockets, within seconds of me plugging in the cable. No power management system would do that.
Sign In or Register to comment.

Who's Online in this Category0