MDC will not add my device — TomTom Community

MDC will not add my device

I now have a further issue
After reinstalling MDC I now get the welcome screen and add device I click on add device and the Go 500 shows (my machine is the Go510) I click on the green add device button and the process starts but after a few minutes I receive the following error message
'We are sorry something has gone wrong. It is currently not possible to add your device to your account. Please try again'
I have checked my device and the actual SatNav system is working so it seems to me that I have an issue with MDC and my device
Any help or suggestions please

Answers

  • rider1riderrider1rider Posts: 63 [Supreme Trailblazer]
    check firewall & antivirus configurations...
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    Firewall anti virus disconnected I mentioned to get it to add my device (I think) but since then now over three hours my device is saying updating Do not disconnect your device but the MDC is saying it cannot connect to my device
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    I also cannot find the tomtom on my device manager doesnt show in either my network adapter or under other devices
  • DougLapDougLap Posts: 4,014 Superuser
    Hi @jacintainspain

    When you say that in My Drive Connect it shows a GO500 is the Serial number displayed correct ie the of your GO510. If so that could explain why it cannot add it again.

    Doug
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    Doug it does not give a serial number just shows Go 500 with a picture of a Go 500 and the connect tab, but my actual device is saying
    Updating
    Do not disconnect your device but its being doing this for over three hours so far so I dont know whether toturn it alll off or just let it keep going
  • DougLapDougLap Posts: 4,014 Superuser
    Hi @jacintainspain

    Do not disconnect it. The serial number usually appears when you start MDC and select the my devices option. The GO500 and GO510 are similar devices which may be reason that it say GO500 but provided the serial number is correct there should be no problem.

    Doug
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    Thanks and yes that was what it used to do before it all went wrong but now it shows no serial number under the Go 500 tag
    I'll leave the device with the updating screen on for as long as possible but the actual MDC screen as gone back to the welcome and add device screen but when I touch the add device green button it just goes back to the 'please connect your device' screen. I am wondering if the cable has got a broken wire somewhere in it hence losing connections
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    This is what I have on my laptop and device and its now been 24 hours like this
    MDC will not add my device and my device is now just a brick have passed this on to TomTom themselves and had no response
    oupmw7lmsz0o.jpg
    ekygwgwveizp.jpg
    f2bjf04dx89w.jpg
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    I have had a total lack of support from TomTom and will never use any of their product again and will not ever recommend them to anybody else
    They never helped solve my issues they just ignored them?
    Really disappointed with your lack of support and will never purchase another product from you if this is an example of your lack of support
    You sent me one email response this morning then no answer to my further issues that i am trying to solve without your support
    Really poor and will inform others of your terrible customer support
    I now have a brick instead of a portable navigation device
    Really annoyed that you have left me in this way
    I hope this serves as a warning to any new potential customers
    Never had such a poor customer service from any other company
  • DougLapDougLap Posts: 4,014 Superuser
    Hi @jacintainspain

    The Tomtom employees will only now be gradually retuning from the Holiday break and so will take time to answer all queries they have received directly. This forum is hosted by Tomtom but is for its customers who try to help other customers to resolve problems. Until today there has only been one Tomtom employee on here as a Mod and that does not include the weekend.

    I assume you have now disconnected your device and so when you boot up the My Drive Connect software does it still display the GO500 when you select My Device and doe sit show the serial number. Is it the same as your GO510

    When you say your device is now bricked does it show that No Mp Found if not what does display when you start it.

    Doug
    A fellow customer
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    Sorry Doug it wasn't this forum I was venting my frustation on but the actual TomTom Support team who seem to not bother to answer questions when they ask the customer for a response
    I know how this forum works and am grateful for any help and assistance offered but Tom Tom customer service itself is not fit for purpose
    All that happens when i turn my device on along with MDC is that it starts yet another update that when left alone is downloading until with 5 mins of completion then goes back to the start again.
    I can use my device with its outdated and corrupt map but I do think there is a serious issue with MDC and its working with the devices when linked and Tom Tom seem to be well aware of this issue but do not want to resolve these issues
    Maybe its because most modern cars have inbuilt sat navs making TomTom irrelevant nowadays
    Thanks for all your help and advice and it is appreciated honestly
    But the company stinks at customer service
  • DougLapDougLap Posts: 4,014 Superuser
    Hi @jacintainspain

    Turn on My Drive Connect with the device NOT connected as it should still show the devices associated with the Account.

    It is usually better to speak to Customer Support as response by Message can take a couple of days or so when things are working normally.

    Doug
  • YamFazManYamFazMan Posts: 15,860 Superusers
    edited December 2019
    Hi
    @jacintainspain

    Are you using a mains Power adapter with the Laptop...
    Is your PC hard-wired to the router or connecting over Wi-Fi
    If over Wi-Fi, how Fast/Slow is the connection, is it stable, how good is the signal strength

    ATB YFM
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    Laptop on mains power and connected via Ethernet direct into router
    I watch iptv films and all download in seconds
    Never had any issues with speed currently at 71.24 Mbps download and 56.37 upload so no issue with speed
    I am certain its an MDC issue that TomTom is aware of as I have read a lot on here and other forums about the poor download speeds using MDC
    But to be honest I have now wasted enough time on this so will just stick to the map installed on my device and not bother with Tomtom again
    Thanks again for all your input into this matter
  • YamFazManYamFazMan Posts: 15,860 Superusers
    Hi
    @jacintainspain

    Re "Download/Installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"

    Win7 See... http://www.sevenforums.com/tutorials/147369-usb-selective-suspend-turn-off.html

    Win10 See… https://www.tenforums.com/tutorials/73187-turn-off-usb-selective-suspend-windows-10-a.html
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Also turn off any Screen savers any other Power savers or USB port monitoring software installed
    ________________________________

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work
    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu
    You will need to edit the Registry for the USB Selective Suspend menu to show

    Laptop users also see Note (1) & (2)
    Note... (1) My Linx 10/10 Win10 Tablet is exactly the same... I had to edit the Registry to activate the advanced setting in the Power Menu
    Note...(2) Recently a User with a Dell XPS 9360 Laptop also exactly the same problem ... he also had to edit the Registry to activate the advanced setting in the Power Menu

    See... https://discussions.tomtom.com/en/discussion/comment/1234855/#Comment_1234855

    Also see... Windows 10 Power Settings for Surface Pro devices
    See... https://www.lovemysurface.net/windows-10-power-settings-for-surface/

    ATB YFM
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    Thanks for that but I am using the same laptop I have always used for connecting MDC to my device and not had this issue before so why now would I get this issue with my usb ports?
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    This is actually stuck in a loop it downloads then takes two hours to load gets to the 'finishing off' screen then goes back to the start and starts again
    So far Tom Tom support have told me its my internet speed, internet signal drop our, virus software, USB ports, and Firewall, all of which have been switched off, i have never conducted an update without my virus or firewall ever needing to be switched off, this issue has only started when it told me that my map was corrupt, and that is the real issue, but nobody at Tom tom knows how to overcome this issue, so my device will just stay as it is and I will not bother to use MDC again
    Easy to say its an internet or laptop issue yet nothing else is going wrong with the same internet and laptop, incidentally I used a friends internet and laptop with the same results so obviously he has a problem with his internet and laptop all of a sudden just like me?????
    I think Tom tom needs to address their own issues, if my map is corrupt and I cannot load a smaller map on to then uninstall the corrupt map, how do I overcome this issue???
    Maybe they could instruct me as to how to rectify the issue rather than blame something that is not the cause
    What a waste of time Tom tom is
    Ps thanks for your advice its much appreciated but does not address the issue which is purely Tomtoms issue and not my laptop or internet, maybe their oversized maps for the supplied sd cards is the real issue
  • jacintainspainjacintainspain Posts: 41 [Master Explorer]
    Just a quick update I hve obtained a brand new scandisk 32GB micro sd card formated it and followed all the advice from TomTom help to reformat and reinstall and guess what yup get the same result telling me that my device does not have room on it and when I look on the MDC all about my device it informs me that there is a corrupt file on there, how its a brand new sd card and that my map already installed is corrupt
    Why does nobody understand that this is an issue with MDC and my device and not my laptop, internet, virus, firewall etc
Sign In or Register to comment.

Who's Online in this Category0