AmiGO - Autostart issue — TomTom Community

AmiGO - Autostart issue

kacnjekacnje Posts: 17 [Master Traveler]
After using SpeedCamera, I got information about AmiGO last week.
I tried it and it works quite well, except "autostart". I select a car's Bluetooth, but it doesn't trigger the AmiGO.
I'm using OnePlus 5 with the latest version of OS (it is Android 9 in my case).
Any idea what can be wrong?
I have another solution (start AmiGO with Tasker) if the app can't do it for some reason.
Tagged:

Comments

  • VikramKVikramK Posts: 11,624 Moderator
    edited December 2019
    Hi @kacnje

    Sorry, I am slightly confused here. So below are some questions-

    1. Could you explain what exactly do you mean by 'autostart' ?

    2. I select a car's Bluetooth, but it doesn't trigger the AmiGO.
    - Is the app installed on your car Android unit?

    3. I'm using OnePlus 5 with the latest version of OS (it is Android 9 in my case).
    - How is the car Bluetooth and your phone OnePlus related here?

    Thank you,
    Vikram
  • kacnjekacnje Posts: 17 [Master Traveler]
    edited December 2019
    Sorry, maybe I wasn't clear enough (English isn't my native language ...).
    1. In "Settings -> Automatic Start" I select/enable my cars BT, so I expect that AmiGO will automatically start when BT will connect to my cars BT (head unit). I mean, when I came into a car with BT on, it will connect (as usually) to headunit and then start AmiGO.

    2. And yes, sometimes I also use Android Auto on the headunit, but I don't see any way to install AmiGO to Android Auto. Is it possible?

    3. How do you mean? I added this information if maybe is some known bug in connection with Android 9.
  • kacnjekacnje Posts: 17 [Master Traveler]
    Yesterday I prepared a profile in Tasker and now it automatically starts AmiGO when the phone connects to a headunit. And kill an application when I leave the car.
  • lampardlampard Posts: 5,227 Moderator
    edited December 2019
    Hi @kacnje

    Can you please double-check Settings > Automatic Start and see if your BL device is configured? Sometimes it takes a bit long for the App to start, even 30 seconds. In your case, AmiGO didn't start also after waiting so long? (Please mention the App version)

    Currently Android Auto only works with Google Maps and Waze for the navigation category. As a result, we cannot develop this feature until support for integration with third-party developers is available.

    Regards, lampard
  • kacnjekacnje Posts: 17 [Master Traveler]
    lampard, tnx for your answer.
    1. BT device is properly configured, but it doesn't start. I'm using AmiGO version 7.108.0. But now it works with Tasker, which has even better features (for example killing the application when I leave the car).
    2. I understand that Android Auto should support an application to work with it. And Google doesn't have an interest in any 3rd party navigation software ...
    3. BTW - AmiGO uses a lot of battery. It can be improved, for sure.
  • lampardlampard Posts: 5,227 Moderator
    Hi @kacnje

    Thank you for providing us with the details. I'll send this to the team for further investigation. About battery consumption, it is higher than in Speed Cam app(old) also because of added navigation. This is in progress to be improved.

    Thanks, lampard

  • SukhiSukhi Posts: 1 [New Seeker]
    I am using amigo app in iPhone 11 , ios 13 software. I can not see any options in settings where i can turn on automatically start app when connected to Bluetooth.
  • lampardlampard Posts: 5,227 Moderator
    Hi @Sukhi

    Welcome to the Community! Bluetooth Autostart/Autostop is not available in AmiGO iOS app.

    Regards, lampard
Sign In or Register to comment.

Who's Online in this Category0