Updating maps returns an invalid archive fotr USA, Canada Maps on a Mazda NB1 unit

RAMFlux Registered Users Posts: 1
New Seeker
edited December 2019 in Map purchase & installation
I just purchased the 2019 maps and the when the TomTom Home application finishes downloading the map sit returns a error "This file is invalid (archive file) ........ USA_Canada.zip when attempts to install it on the SD Card.

I noticed activation file DCT is not included in the download for the latest map.

What can I do to fix this?

I am running Windows 10 (1909 build) 16GB of RAM and latest TomTom Home Application.


  • VikramK
    VikramK Administrators Posts: 14,303
    Hi @RAMFlux

    Welcome to the community!

    This invalid archive error is related to an ongoing issue; please report this to the customer service.

  • veh
    veh Registered Users Posts: 1
    New Seeker
    I have the exact same issue.
  • Spikeydragoon
    Spikeydragoon Registered Users Posts: 4
    Master Traveler

    Posting here instead of creating my own post since same issue and i wanted to provide some more info which is at the bottom.

    Just purchased new map update and i am having this issues as well. Do we have an eta on a fix?

    Contacted support using the email option Thursday or Friday since US does not have an option for phone. So far no reply other than the automated system.

    Looks like this has been an issue for a year now. I noticed on one post they said a fix was issued December and a few users said it was fixed, however since this is same problem i do not think it was fully fixed or something re-broke it.

    I did attempt some troubleshooting on my own before coming here to notice it was an ongoing issue.

    What i ran across in my testing.

    As said above and in multi post it downloads the map.zip to the complete folder however once the tomtom home
    (Which i dislike so buggy. Basically it has an issue getting to the home page of the program when you first launch it. To get there i found workaround is to hit the disconnect button home page shows up then plug your device back in and boom it works fine and allows you to hit the back/done button to go to the home page. Before button didnt do anything)
    goes to install the map it shows the invalid error above.

    ** Troubleshooting info below **

    So i tried the steps in their manual install guide and unzipped the map to the correct folder and boom map showed updated. It showed a few quick fixes available now which it updated and installed just fine so i thought great its ready to roll. Put the chip into the Mazda and once it started up instead of doing the usual map update screen it said can not use this map on this device.

    After doing some more digging in tomtom home manage device option i noticed it said it could not use the map due to being not activated. When you click active it wants a code that was not supplied in the purchase email or any where that i saw.

    So sounds like it is coming down to the downloaded map not being activated which might be why tomtom home is saying the map is invalid.

    Is this something someone can look into or pass it on to tomtom since im unable to get a hold of them? Also moderators feel free to message me directly if you know how to active my purchased map and i can test if that is a fix or not.
  • dhn
    dhn Posts: 33,388
    Phone support for US:

    United States
    Monday - Friday: 9:30 a.m. to 6:00 p.m. EST
  • Spikeydragoon
    Spikeydragoon Registered Users Posts: 4
    Master Traveler
    @dhn oh nice, thank you.
  • Spikeydragoon
    Spikeydragoon Registered Users Posts: 4
    Master Traveler
    @RAMFlux @dhn @VikramK @veh
    Just to update everyone so spoke with support and they released a new tomtom home update today that fixes this issue and the issue i mentioned above :)

    Just so everyone is aware as well apparently my tomtom home had an issue detecting the update and kept saying i had the lastest. I had to uninstall and download the newest version from tomtom site.

    After that everything worked perfect. So just keep in mind you might have to reinstall tomtom home to fix the issue above.