so why am i now being asked to pay £29.99 for speed cameras that is supposed to be free — TomTom Community

so why am i now being asked to pay £29.99 for speed cameras that is supposed to be free

TOMTOM you are a joke, first it takes you three days to do a next day delivery and now when i set up the new satnav you want £29.99 for what is meant to be free

Best Answer

Answers

  • dmulvdmulv Posts: 667
    Superuser
    There's definitely something amiss with your account, as all devices come with free speed cameras out of the box - the only difference between them is how long the access to updates lasts for.

    Go Basic = 3 months
    Go Essential = 6 months
    Go Premium = lifetime

    So as Doug says, call customer support and get them to sort it out for you.
  • John-JayJohn-Jay Posts: 699 [Revered Pioneer]
    dmulv wrote: »
    There's definitely something amiss with your account, as all devices come with free speed cameras out of the box - the only difference between them is how long the access to updates lasts for.

    Go Basic = 3 months
    Go Essential = 6 months
    Go Premium = lifetime

    So as Doug says, call customer support and get them to sort it out for you.

    Unfortunately TomTom seems to "enjoy" causing confusion! Under MyDriveConnect my GO 520 is listed as a GO Essential, yet I have Lifetime Camera & Traffic support!

  • lampardlampard Posts: 5,142 Moderator
    Hi @DrewMoore

    Welcome to the Community! Can you please make a soft reset on your device and check again? Your lifetime speed camera update should be active now.

    Regards, lampard
  • BaserBaser Posts: 2 [Apprentice Traveler]
    HI all
    just purchased a new tt go premiium x .
    why am i being told Speed camera,and Traffic expires soon?
    Are these not lifetime
    Help please or it will gp back


  • DougLapDougLap Posts: 7,285
    Superuser
    Hi @Baser

    Contact Customer support to get your account sorted as they are lifetime..

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    Don't answer the questions but wait for an agent to answer.

    Doug
  • BaserBaser Posts: 2 [Apprentice Traveler]
    Hi Doug
    thanks
    just spoke to CS and for some reason my account not set up correctly,although my tt5100 working fine on the same account.
    But all working now thanks

    Baser
  • DougLapDougLap Posts: 7,285
    Superuser
    Hi @Baser

    That was quick. Pleased you are sorted. Your unit will have worked okay because your account probably had the traffic as free for 3 or 6 months instead of Lifetime.

    Doug
Sign In or Register to comment.

Who's Online in this Category0