My device doesn't show any cameras. 30 days ago it did. Why. — TomTom Community

My device doesn't show any cameras. 30 days ago it did. Why.

The device tells me it is updated.
Can you help me?
Thank you
Tagged:

Answers

  • YamFazManYamFazMan Posts: 19,431
    Superusers
    edited October 2019
    Hi
    @Stefano_Guazzieri

    Ring Tomtom Support to check your Account....
    Tomtom Support Italia
    0245281004
    lunedì-venerdì: ore 09:00-17:30 CET
    ______________________

    For general improvement using the Tomtom Speed Cam Database over the default settings

    Always use a Computer voice...
    From the main screen... Tap (.... Menu) -> Setting -> Sounds & Warnings...
    Set... 'Warning Type' to... Read Allowed... (Important... Needs a Computer Voice set in the Voices menu)
    Speed Cameras & Hazards... Set to ON
    The next 10 Setting ALL set to Always
    The next 4 Settings ALL set to ON
    The device will now say....
    'Fixed Camera'
    'Mobile Hot Spot'
    'Average Speed Camera Zone'
    'Red-light Camera'
    'Accident Black-spots
    ‘Spoken Traffic delays’


    Speed Cams
    If you keep a check on the Traffic-bar... The device gives you a visual Warning of the next Fixed or Mobile Speed Camera many miles before you reach the camera
    Even more info if in the 'Setting menus' you setup a Wide Traffic/Route Bar
    93197384-69ec-4f9d-b7ae-f68a6f82ffae.jpg
    Also Check....
    Tap 4Dot (.... Menu) -->

    x74lfsacxhur.jpg
    ATB YFM
Sign In or Register to comment.

Who's Online in this Category0