Device does not show in Device Manager — TomTom Community

Device does not show in Device Manager

vgibertinivgibertini Posts: 2 [Apprentice Traveler]
edited October 23 in MyDrive Connect
Hello,
I have been trying to update my device through MyDrive Connect but I cannot find a way to connect my TomTom device to my laptop.
When I connect it, it shows as "connected" in MyDrive Connect for about 30 seconds, then the connection is lost. Furthermore, the device never appears in Device Manager. However, on the device's screen I always see "Connected to your computer", even when MyDrive Connect says it is not connected.

I have tried everything I could think of, reinstalled MyDrive Connect several times, contacted TomTom support that even sent me a new cable, but when I told them that I tried connecting to a friend's PC and it worked (but it didn't work with the PC of another friend), they said it's not their problem because the device works. Apparently as long as it can connect to 'some' PC, then I'm on my own. Very unhelpful.

Anyone has any idea?

Thanks.

Best Answer

Answers

  • vgibertinivgibertini Posts: 2 [Apprentice Traveler]
    It seems to be working now.
    I had changed the settings in the Power Menu but not the registry. That was probably the issue.
    It would be nice if TomTom support actually knew this. I have spent almost a month of back and forth.
  • YamFazManYamFazMan Posts: 15,245 Superusers
    Hi
    @vgibertini

    You're welcome, glad you're sorted :)

    ATB YFM
  • lampardlampard Posts: 4,315 TomTom Moderator
    Hi @vgibertini

    Welcome to the Community and I'm glad to know that you found what you were looking for! When you get a chance, click 'Yes' on YamFazMan's comment above to mark it as an answer. This will help others with similar concerns to find it. :)

    Regards, lampard
Sign In or Register to comment.

Who's Online12

TomDone
TomDone
+11 Guests