Speed cameras are available only with wifi — TomTom Community

Speed cameras are available only with wifi

MarttiTreiMarttiTrei Posts: 4 [Apprentice Traveler]
After latest update my Go 620 Wifi is showing speedcameras only if device is connected with wifi.
Is there any way to get them work also with offline mode ? I don't want to use mobile data if I travel to some other countrys ?

Answers

  • DougLapDougLap Posts: 6,923
    Superuser
    Hi @MarttiTrei

    Someone who recently mentioned this problem said that a Factory Reset sorted it.

    Tap Menu
    Tap Settings
    Tap System
    Tap Reset Device.

    This will delete all your data ie Favourites (My Places and any Poi and Route files you have loaded on the unit. If you go to the My Drive Website and log into your account the data should be there and so if it is will be synced back onto the device after the reset.

    You will have to set the device up again as you did out of the box.

    All the best.

    Doug
  • MarttiTreiMarttiTrei Posts: 4 [Apprentice Traveler]
    edited October 2019
    No it won't help, already tried this method
  • VikramKVikramK Posts: 10,933 Moderator
    Hi @MarttiTrei

    For speed cameras locations which are already installed on your device, you will continue to get alerts when the device is not connected to a smartphone(internet data)

    But for speed cameras locations that get updated in real-time, you will need to have the device connected to a smartphone. These updates get installed on the device over the air when you travel on a planned route.

    You mention about traveling to different countries, I would recommend that you check out the coverage under the specification for your GO Essential device.

    Thank you,
    Vikram :)
  • MarttiTreiMarttiTrei Posts: 4 [Apprentice Traveler]
    Hi @VikramK
    It's not giving me alerts for cameras that should be on device, cameras dissapear when I disconnect my device from internet.
    It's tested in Estonia, Finland and Latvia at the moment, It was working before the latest update but now they are gone.
    Is there any way to make firmware downgrade or can TomTom do anything about this problem, I searched this problem from internet and I know am not the only one who have this error.
  • JanatuneJanatune Posts: 3 [Neophyte Traveler]
    Word @MarttiTrei !!
    Same sh×t over hire. This latest update went to south big time, and all I can get is some typical soft/factory reset..and it aint't helping! My device is tt via 53.

    Some say it was before new year that the update got the cameras off..and no help has come.

    Does someone know tomtom customer service number for Finland? On the finnish tomtom site there is only faq and chat with tomtom community member..


    @VikramK
  • DougLapDougLap Posts: 6,923
    Superuser
    Hi @Janatune

    There is no phone contact facility in Finland, only a chat facility is available.

    Have you got a current cameras subscription or does it need renewing?

    Doug
  • JanatuneJanatune Posts: 3 [Neophyte Traveler]
    Hi, and thanks for quick reply.
    Yes, I have current camera subscription and tt was working fine (on/offline) before update.
    Now cameras are working only online
  • JanatuneJanatune Posts: 3 [Neophyte Traveler]
    Update!
    Tomtom customer service did some update programming(?), and yesterday I got my tt via 53 updated and now cameras work on-/offline 👍🏻
Sign In or Register to comment.

Who's Online in this Category0