GO 5000 stuck on loading screen

akis_t
akis_t Registered Users Posts: 4
Master Traveler
Hello, my GO 5000 has been stuck on loading screen, when it starts it does the drumroll sound and displays the "TOMTOM" banner and it stays there for ever, or at least until the battery dies. Holding the power button down for about 15 seconds switches it off. Plugging in the USB from the PC auto-switches it on with the same drum roll and banner on screen, but the PC does not see it. If I switch it on and leave it (not connected to the PC) it will stay on the loading screen forever and eventually drain the battery completely. I initially suspected a bad battery so I replaced it but it still behaves exactly the same as it did before. Is there a way I can salvage this or is it going in the bin? Many thanks

Answers

  • DougLap
    DougLap Posts: 10,050
    Superuser
    Hi @akis_t

    Can you see if you can do the following. The three taps is the tricky bit. You will be lucky if you can get the taps right first time.

    https://discussions.tomtom.com/en/discussion/1034277/how-to-recover-your-device/p1?new=1

    Good luck

    Doug
  • akis_t
    akis_t Registered Users Posts: 4
    Master Traveler
    Hi, thanks for the reply. When I hold the power button down it will switch off after about 13-15 seconds and nothing happens if I hold it down for less.
  • E_Calvert2021
    E_Calvert2021 Registered Users Posts: 1
    New Seeker
    This has also happened to me, it simply won't go move off the TomTom drumroll screen at all - is there any other way to hard reset please?
  • dk-alan
    dk-alan Registered Users Posts: 2
    Apprentice Traveler
    I have the same problem as described above. Has any reply or solution ever been found?
  • YamFazMan
    YamFazMan Posts: 21,155
     Superuser
    Hi
    @dk-alan
    If you have a Micro SDHC memory card installed... Remove the Memory Card & try rebooting....

    Stay safe... ATB YFM
  • dk-alan
    dk-alan Registered Users Posts: 2
    Apprentice Traveler
    Hi ATB YFM,

    Thanks for your suggestion. I do have a memory card and tried to restart after removing it. Unfortunately no difference. The Go 5000 just keeps rebooting with the logo and drums. It won't get out of the loop.
    Any other ways of hard resetting?