My Go 620 can't make speed camera warning in the cruise mode and can't get speed camera update — TomTom Community

My Go 620 can't make speed camera warning in the cruise mode and can't get speed camera update

In the morning of 19 September, I received a message to update the software and speed camera in my GO 620. I performed that and canceled once due to the unstable wifi connection. After that, I found I could not receive any speed camera update in this week and the speed camera warning disappeared on the cruise mode (without destination mode).

I did many times of soft reset but the device didn't get any speed camera update. Does anyone have cue?

Best Answer

  • chrischenggeologistchrischenggeologist Posts: 2 [Novice Seeker]
    Accepted Answer
    Thank you. I am sorry I didn't reply you timely.

    Actually in the night of 26th September, I connected the device with my computer and a camera update appeared.

    It was bit of strange since this update didn't appear on wifi connection.

Answers

  • VikramKVikramK Posts: 10,486 Moderator
    Hi @chrischenggeologist

    Welcome to the community!

    Just reviewed the logs for your device and I find that the latest package of updates(speed cameras) was installed on 26th September.

    If you have a cloud back your saved places and routes(using MyDrive) please do a factory reset.

    Main menu- Settings-System- Reset Device

    Once done plan a route and test it out.

    Regards
    Vikram
  • chrischenggeologistchrischenggeologist Posts: 2 [Novice Seeker]
    Accepted Answer
    Thank you. I am sorry I didn't reply you timely.

    Actually in the night of 26th September, I connected the device with my computer and a camera update appeared.

    It was bit of strange since this update didn't appear on wifi connection.
  • YamFazManYamFazMan Posts: 17,770
    Superusers
    Hi
    @chrischenggeologist
    My Go 620 can't make speed camera warning in the cruise mode
    See below... A quote from a previous post of mine
    YamFazMan wrote: »
    Hi
    Out today... Using my GO 520 in the UK
    I drove around without route planned
    Using the 2D, 3D and the North up Overview Maps
    In all three Modes, the device warned of.....
    Exceeding the Speed Limit
    Fixed Speed cameras
    Mobile Speed camera Hot Spots
    Average speed camera zones (Motorway)

    I can see any reason why.....
    Approaching Stationary Queuing Traffic
    Red Light Camera... Wouldn't also Show

    Any 3rd Party POI you have loaded and set to display on the Map... All display the Tomtom generic Icon OK

    I didn't Notice if petrol stations were displayed on the map or not
    _____________________________

    For general improvement for a NAV 4/5(Wifi) device over the default settings

    Use a Computer voice...
    Also....
    From the main screen... Tap (.... Menu) -> Setting -> Sounds & Warnings...
    Set... 'Warning Type' to... Read Allowed...
    (Important... Needs a Computer Voice set in the Voices menu)
    Speed Cameras & Hazards... Set to ON
    The next 10 Setting ALL set to Always
    The next 4 Settings ALL set to ON
    The device will now say....
    'Fixed Camera'
    'Mobile Hot Spot'
    Spoken Traffic delays
    Red Light Camera
    ATB YFM
Sign In or Register to comment.

Who's Online in this Category0