Bluetooth connectivity issues for Wi-Fi devices and iOS 13 - Page 12 — TomTom Community

Bluetooth connectivity issues for Wi-Fi devices and iOS 13

191012141523

Comments

  • Nigel ANigel A Posts: 123 [Renowned Trailblazer]
    Cant believe this, Have deleted the app etc. turned on my 520 and got Bluetooth and traffic !!! even rang the phone and it worked !!! Oh hang on..... that was my 30 seconds worth, now lost hands free after the call. Hang on again !!!! hands free is back and I still have traffic. will bung it in the car later and try again tomorrow .... I live in hope .....
  • juresjures Posts: 101 [Sovereign Trailblazer]
    Tried on friends - does not work
  • juresjures Posts: 101 [Sovereign Trailblazer]
    correction it seems it works.....so clearly app problem?
  • jicemanjiceman Posts: 21 [Master Explorer]
    edited January 2020
    Cyborg1963 wrote: »
    I tried right now to reconnect it
    qx6fdgmrpkhl.jpg

    I am using a Go 620. I can confirm that when no app is installed on the iPhone running 13.3 and I set the phone to allow a hotspot but then connect only with Bluetooth (no WiFi connection at all), then I do get traffic and a connection to MyDrive.

    I agree that this is an improvement. However, it is still not as good as connecting to the phone using WiFi (better speed, longer range and seems better for phone battery life as well). Under iOS 12, I always connected to my iPhone using WiFi.

    ---

    I received a comment by email from another user (for unknown reasons, it is not visible in the thread) who suggested that Bluetooth should be better for phone battery life as compared to WiFi (if using one or the other). So, if I reconsider it seems like a fairly decent solution (speaking as someone who didn't use the MyDrive app often on iOS).
  • juresjures Posts: 101 [Sovereign Trailblazer]
    edited January 2020
    Wifi has no point here, because traffic is 10k per month of data....
    For sure wifi willl burn more battery on phone.
    Bluetooth is far the most prefered way

    Regarding improvement, this is a set back, because it is a workaround found by users, but we lost the app which is needed to manage the routes.
    But users just got brakethrough and I hope tomtom is at least reading - this is 100% proof that issue is not in ios13
  • juresjures Posts: 101 [Sovereign Trailblazer]
    So traffic and mydrive works for surethis way but smartphone features do not. Its clearly a fight within functionalities.
    with app: no traffic but smartphone functionalities
    without app: traffic but no smart functions

    During setup with the app we have dual BT connections, on for traffic and one for smartfunctions. Something Tomtom needs to take care of
  • Nigel ANigel A Posts: 123 [Renowned Trailblazer]
    Well I tried again last night, after the obligatory resets I got Bluetooth hands free for about 35 seconds - is this a record ? Also not that I get email notifications of posts to this thread that never appear ? removed ?
  • juresjures Posts: 101 [Sovereign Trailblazer]
    Nigel A wrote: »
    Well I tried again last night, after the obligatory resets I got Bluetooth hands free for about 35 seconds - is this a record ? Also not that I get email notifications of posts to this thread that never appear ? removed ?

    Like I said above without app no smart phone features with app smart features and vice versa For traffic

  • Nigel ANigel A Posts: 123 [Renowned Trailblazer]
    edited January 2020
    Jures, I don't get to see your posts ? (And some others) cant work out why?
  • juresjures Posts: 101 [Sovereign Trailblazer]
    Nigel A wrote: »
    Jures, I don't get to see your posts ? (And some others) cant work out why?

    Have no clue why.....
  • Nigel ANigel A Posts: 123 [Renowned Trailblazer]
    jures wrote: »
    Nigel A wrote: »
    Jures, I don't get to see your posts ? (And some others) cant work out why?

    Have no clue why.....

    That's odd, now I have your threads ??? at least I can follow the conversations again !!!!
  • juresjures Posts: 101 [Sovereign Trailblazer]
    13.3.1 officialy released
  • AndersNordhAndersNordh Posts: 276 [Supreme Navigator]
    jures wrote: »
    13.3.1 officialy released

    ... and still the same issue as before...😫

    /Anders

  • juresjures Posts: 101 [Sovereign Trailblazer]
    edited January 2020
    jures wrote: »
    13.3.1 officialy released

    ... and still the same issue as before...😫

    /Anders
    Ues because its not ios issue. If you pair gps with iphone without mydrive app traffic works flawlessly - perfectly!
    You can even install after mydrive app and use it for routing JUST DONT PAIR gps over the app!!!
    Traffic will still work, my drive routing will work, the only thing that does not work will be smartphone features (calls / sms) but thats not important on bike.

    Traffic and mydrive under ios works!!!!!
    - Delete app
    - Delete old BT pairings of gps
    - Connect gps to phone over bluetooth under standard way
    - Install app
    - DO NOT pair gps over the app
    - have personal hotspot on phone turned ON just for BT
    - DO NOT pair gps with wifi of this personal hotspot

    TRAFFIC AND MY DRIVE WILL WORK NON STOP!!

    Problem is in the app (pairing through the app)
  • TerrieristTerrierist Posts: 4 [Apprentice Seeker]
    edited January 2020
    [quote="j

    Traffic and mydrive under ios works!!!!!
    - Delete app
    - Delete old BT pairings of gps
    - Connect gps to phone over bluetooth under standard way
    - Install app
    - DO NOT pair gps over the app
    - have personal hotspot on phone turned ON just for BT
    - DO NOT pair gps with wifi of this personal hotspot

    TRAFFIC AND MY DRIVE WILL WORK NON STOP!!

    Problem is in the app (pairing through the app)
    [/quote]

    Thank you, thank you, thank you!!

    To anyone else frustrated with this, the above worked for me after a full reset and getting rid of MyDrive app, reinstalling etc...

    TomTom, come on, I've wasted four hours of my life sorting this out. Plus, My device was brand new in the box. God help anyone else who buys one that isnt a little bit clued up. Shocking.
  • Nigel ANigel A Posts: 123 [Renowned Trailblazer]
    Now have ios 13.3.1 ! =) I have Bluetooth hands free phone symbol up ! =) seems permanent ! =) Ahhh....... of course if I ring my mobile the Bluetooth hands free dose'nt actualy do anything........... :/ Ah well back to on / off / reset / throw tom tom across the room :s
  • juresjures Posts: 101 [Sovereign Trailblazer]
    Nigel A wrote: »
    Now have ios 13.3.1 ! =) I have Bluetooth hands free phone symbol up ! =) seems permanent ! =) Ahhh....... of course if I ring my mobile the Bluetooth hands free dose'nt actualy do anything........... :/ Ah well back to on / off / reset / throw tom tom across the room :s
    Read my post.

  • AndersNordhAndersNordh Posts: 276 [Supreme Navigator]
    edited January 2020
    jures wrote: »
    jures wrote: »
    13.3.1 officialy released

    ... and still the same issue as before...😫

    /Anders

    Traffic and mydrive under ios works!!!!!
    - Delete app
    - Delete old BT pairings of gps
    - Connect gps to phone over bluetooth under standard way
    - Install app
    - DO NOT pair gps over the app
    - have personal hotspot on phone turned ON just for BT
    - DO NOT pair gps with wifi of this personal hotspot

    TRAFFIC AND MY DRIVE WILL WORK NON STOP!!

    Hi,

    Well, this fail for me already at the third step. The connection work for like 15-30 seconds, then it fails and it takes from 10-60 seconds until it reconnects for another 15-30 seconds, then it fail again and so on forever ...

    ... so no, it does not work ... on my IPhone 8, nor on the 6s ...

    /Anders
  • juresjures Posts: 101 [Sovereign Trailblazer]
    edited January 2020
    Did you delete all Old bluetooth connections in phone and gps? Works perfectly for n friends 6,7,8 and my 10

    Delete also wifi connections
    And do not forget to turn on iPhones hotspot. It's normal at the third step not to work if you don't have this on
  • TerrieristTerrierist Posts: 4 [Apprentice Seeker]
    jures wrote: »
    Did you delete all Old bluetooth connections in phone and gps? Works perfectly for n friends 6,7,8 and my 10

    Delete also wifi connections
    And do not forget to turn on iPhones hotspot. It's normal at the third step not to work if you don't have this on

    Just done a full day testing the unit with Jures' workround and it hasn't missed a beat. Only thing missing are text messages, I can live with that until sorted fully. Today involved 430 Km with nine destinations - all posted from Go to unit (620 Professional)
  • DougLapDougLap Posts: 8,254
    Superuser
    edited January 2020
    There is one thing I have noticed about the latest IOS13.3.1 which I link to my GO5200. As with previous attempts whilst the Handsfree has linked and worked any attempt to link via the My Drive App for Smartphone Messaging would lose the connection within about a minute at most, if it would connect at all.. I cannot comment re Traffic as the GO5200 uses the inbuilt Sim.

    With this update I have managed to link via the My Drive App and receive a number of messages, which I was not able to do since upgrading to IOS13, and have had the connection remain Connected for as much as an hour or more. It is clear the problem is not completely solved but I find it interesting that although the IOS update makes no reference to resolution of Bluetooth bugs there does appear there could. be some change in the IOS that has shown change from what has been happening...

    Doug
  • Nigel ANigel A Posts: 123 [Renowned Trailblazer]
    Iteresting, but still no hands free. seem a long winded way to get traffic, which I can get via a straight wi fi hot spot ?
  • juresjures Posts: 101 [Sovereign Trailblazer]
    Terrierist wrote: »
    jures wrote: »
    Did you delete all Old bluetooth connections in phone and gps? Works perfectly for n friends 6,7,8 and my 10

    Delete also wifi connections
    And do not forget to turn on iPhones hotspot. It's normal at the third step not to work if you don't have this on

    Just done a full day testing the unit with Jures' workround and it hasn't missed a beat. Only thing missing are text messages, I can live with that until sorted fully. Today involved 430 Km with nine destinations - all posted from Go to unit (620 Professional)
    Exactly. And I never used SMS even before, this is stupid And useless on motorcycle so it can be missed.

    And even after you can fully use mydrive app to make routes, send destinations to device etc because the connection to my drive works. JUST DONT PAIR OVER THE APP.


  • DougLapDougLap Posts: 8,254
    Superuser
    edited January 2020
    Hi @Nigel A

    If I connect my phone to my GO5200 via Bluetooth I get Handsfree as normal. The thing is the Smart Messaging option does not always connect or if it does may be for a short period although I have had it remain connected and receive messages for at least an hour on one occasion.

    Can you not Bluetooth for handsfree and Wifi for Traffic and not involve the App at all.

    Doug
  • DougLapDougLap Posts: 8,254
    Superuser
    Hi @jures

    If you are referring to the fact that you can create a route on the My Drive App but it does not then sync to the Tomtom Go Navigation App then this is because the Map on the My Drive App/PND's is different to the maps on the Mobile App.

    TT recently issued a new Android App and that does not sync the route either although the version before Synced My Places and My Routes etc as the PND's. TT have said this is because the new App maps are different, NTS maps I think, but the are working on restoring the syncing facility. The ability to sync the Routes has never been on the Apple version probably because Apple have not allowed it as clearly TT have provided it for the Android in the past and so clearly wish it to be so.

    Doug
Sign In or Register to comment.

Who's Online in this Category0