Bluetooth connectivity issues for Wi-Fi devices and iOS 13 — TomTom Community

Bluetooth connectivity issues for Wi-Fi devices and iOS 13

lampardlampard Posts: 4,211 TomTom Moderator
edited October 22 in News and announcements
Hi All,

The latest iPhone software update (iOS 13, released on the 19th of September) impacts the Bluetooth connectivity of Wi-Fi devices. This prevents you from using features such as Siri, Hands-Free Calling and TomTom MyDrive.

TomTom Traffic and Speed Camera Alerts might also be affected.

Note: You can check if your iPhone is using iOS 13 by opening Settings on your phone, then tap General, and finally About to see your version number.

If you are unsure of which navigation device you have, click this link to find out if it updates with Wi-Fi or not. We have released a software update for your device, and you can retain the Bluetooth functionality by following these steps:

1. Update your device
The software update is offered when you open the Main Menu and select Settings, then Updates. Choose the updates you want to install, then select Update now.

2. Set up the pairing between your iPhone and your device
First, make sure to go to Settings > Bluetooth on your iPhone, and forget your device if it shows up in the list of previously paired devices.

Then pair your iPhone and your navigation device as if it was for the first time.

Thanks, lampard

«134

Comments

  • AndersNordhAndersNordh Posts: 266 [Exalted Navigator]
    After this update, my Rider 550 get connected to BT for a few seconds. loses the connection for 30 seconds, regain the connection again and so on ... :-(
    Please correct this and give us a new update, but a working one ...
    /Anders
  • SerhanSerhan Posts: 4 [Master Traveler]
    I just updated my Rider 550 and it still works fine, nothing has changed. No connection issues or else. I did'nt foget and repair my iPhone.
  • AndersNordhAndersNordh Posts: 266 [Exalted Navigator]
    Serhan wrote: »
    I just updated my Rider 550 and it still works fine, nothing has changed. No connection issues or else. I did'nt foget and repair my iPhone.

    Maybe that is the trick, not to delete the existing BT connection. I have 2 IOS 13 devices, none of them work now ... :-(

    /Anders
  • martin.scott17_un40martin.scott17_un40 Posts: 10 [Legendary Explorer]
    I wish you could fix the issue with hauwei Pro 20. Bluetooth work but txt messages is hit and miss. Keeps saying to far away but it's right next to it.
  • AndersNordhAndersNordh Posts: 266 [Exalted Navigator]
    edited September 23
    Ok, tried again ...

    Performed a factory reset of the unit, that did not help the situation ...

    Rebooted the device, did the three tap thing and got it to download the software via my pc and MyDrive Connect, got an older version and now it all worked fine again. Was then "forced" to update to the latest version and the Bluetooth connection went all crazy again even without deletion of the existing Bluetooth connection.

    So no, this does not work for me, not at all ... :-(

    I have reported this to the support as well, ticket ID 190920-xxxxxxx


    Anders


    Mod edit: Please don't post private or personal information on a public forum. Thanks!
  • smudger64smudger64 Posts: 44 [Renowned Trailblazer]
    Since my 550 never worked with IOS11 or 12 I was hoping IOS13 and a Rider update would fix the problem, but it seems to have got worse!
    What ever happened to Apple buying out Tomtom?!
  • BRussoBRusso Posts: 4 [Master Traveler]
    I have a 520 and have the same problem, my phone updated to iOS13 and now won't connect. i updated the TomTom software with no change. I reset the 520, deleted the phone from the 520 and the 520 from my phone a number of times; nothing works.
  • timmystimmys Posts: 16 [Outstanding Explorer]
    Well done on getting this out in a timely fashion.

    Just a pity it's useless as the MyDrive app crashes on log in if you re-install it while running iOS 13.
  • AndersNordhAndersNordh Posts: 266 [Exalted Navigator]
    timmys wrote: »
    Well done on getting this out in a timely fashion.

    Just a pity it's useless as the MyDrive app crashes on log in if you re-install it while running iOS 13.

    +1 for me, just crashes ...

    /Anders
  • e-squarede-squared Posts: 13 [Legendary Explorer]
    The MyDrive app crash on log in needs to be fixed now. Without being able to log in my gps does not receive traffic data and the app does not upload traffic data. The system will be missing a bunch of data points.

    This is top priority, MyDrive app on iOS 13.

    Thank you
  • KennerPLKennerPL Posts: 9 [Master Explorer]
    TomTom MyDrive app still crashes on iOS 13.
  • jte71jte71 Posts: 10 [Legendary Explorer]
    edited September 23
    Hmm, it's getting worse and worse; connecting my Cardo and the next moment it's gone. This is so sad :s

    My situation is that Cardo can only connect to or my Smartphone or the rider 550. Pfff
  • e-squarede-squared Posts: 13 [Legendary Explorer]
    Just spoke with phone support and you'll never guess, I was the first person to report this issue. Imagine that. So now they are going to vote on it to see if it is a real problem.

    When their traffic data coming in drops off they will make it a priority.
  • fergussionfergussion Posts: 65 [Prominent Wayfarer]
    Add me to the list. mydrive does not work post the iOS 13 update.
  • VikramKVikramK Posts: 8,159 TomTom Moderator
    edited September 24
    Hi @e-squared @fergussion

    Edit-

    The crashes with the MyDrive app iOS have been fixed and these will be covered in the upcoming release.

    We are just waiting for Apple to roll this out.

    Inconvenience caused is regretted.

    Regards
    Vikram
  • e-squarede-squared Posts: 13 [Legendary Explorer]
    Vikram,

    It's official, 2.10.1 is out and log in works.

    Thank you
  • JürgenJürgen Posts: 4,974 Community Manager
    e-squared wrote: »
    Vikram,

    It's official, 2.10.1 is out and log in works.

    Thank you
    This is North America only. Europe and the rest of the world are still pending.
  • VikramKVikramK Posts: 8,159 TomTom Moderator
    edited September 26
    The release is now available for download for Europe and the reset of world!

    Thanks
    Vikram
  • ThijsosThijsos Posts: 2 [Apprentice Seeker]
    I downloaded the update of MyDrive. It seems to stabilized the Bluetooth connection a little bit. The wifi connection also is possible again between the iPhone and my Rider 550 . But the problem i have at the moment is that MyDrive services won’t connect on the Rider 550 when i us the wifi connection from my iPhone. When i use the wifi connection from home there is no problem.
    Disconnect everything and making a new connection didn’t work either.
    Is there a solution for this problem?
  • AndersNordhAndersNordh Posts: 266 [Exalted Navigator]
    Well, now on IOS 13.1, BT connection still comes and goes with or without Mydrive so quite unstable. This is not working ...
    /Anders
  • B van BreukelenB van Breukelen Posts: 2 [Apprentice Seeker]
    I also installed this on my Essential GO and also here bluetooth connection is buggy.
    FIrst install, bluetooth connects, mydrive app also connects and things seem to work. After a minute, mydrive app doesn't see the tomtom anymore. More over, I don't get traffic updates and can't connect to my account (on the tomtom). It keeps showing that it is trying to connect to traffic and the tomtom account. The phone is connected (seen both on tomtom and the phone (iPhone 11 pro, iOS 13.1.1). The tomtom has the latest updates installed. Basically there is no data send over the bluetooth connection.
    The only way to connect to traffic and tomtom account is via a WIFI hotspot on my phone.
    Basically the update v19.104 is not solving the bluetooth issues.

    - I tried to reinstall the app twice, forget and add the phone (bluetooth).
    - I tried the reset to factory default on the tomtom essential Go..

    Same issue persists.

    I hope we can expect a better update of the system software soon?
  • DougLapDougLap Posts: 3,213 Superuser
    Hi @B van Breukelen

    I would like to suggest that you completely Delete / Forget the Bluetooth Settings on the Phone and Essential and tun both units Off and On again. Now go through the Bluetooth set up but out of range of the Wifi to see if the resolves it.

    Doug
  • AndersNordhAndersNordh Posts: 266 [Exalted Navigator]
    DougLap wrote: »
    Hi @B van Breukelen

    I would like to suggest that you completely Delete / Forget the Bluetooth Settings on the Phone and Essential and tun both units Off and On again. Now go through the Bluetooth set up but out of range of the Wifi to see if the resolves it.

    Doug

    Hi, I have done that so many times now I 've lost count, just does not work ... I also try without the Mydrive app by just connecting to TTR550 to the IPhone bot no luck ... Connection comes and goes ... Good that it is not peak riding season now, hopefully they get it sorted until March 2020 ... ;-)

    /Anders
  • KennerPLKennerPL Posts: 9 [Master Explorer]
    I also installed this on my Essential GO and also here bluetooth connection is buggy.
    FIrst install, bluetooth connects, mydrive app also connects and things seem to work. After a minute, mydrive app doesn't see the tomtom anymore. More over, I don't get traffic updates and can't connect to my account (on the tomtom). It keeps showing that it is trying to connect to traffic and the tomtom account. The phone is connected (seen both on tomtom and the phone (iPhone 11 pro, iOS 13.1.1). The tomtom has the latest updates installed. Basically there is no data send over the bluetooth connection.
    The only way to connect to traffic and tomtom account is via a WIFI hotspot on my phone.
    Basically the update v19.104 is not solving the bluetooth issues.

    - I tried to reinstall the app twice, forget and add the phone (bluetooth).
    - I tried the reset to factory default on the tomtom essential Go..

    Same issue persists.

    I hope we can expect a better update of the system software soon?

    I have a very similar issue with my GO Premium after the last update. On my iPhone only one TomTom GO Premium bluetooth connection is working. Because of that some fuctions are not working at all: Traffic and Messages from phone are unavailable. Only speakerphone is connected.

    I also tried to reset to factory my device, forget and add phone etc. Nothing seems to help.
  • Naddy37Naddy37 Posts: 1 [Apprentice Seeker]
    I'm about to launch my unit out the car window with frustration.

    Both iPhone and tomtom Go 53 unit have been fully updated with the latest updates. At least now I can log into MyDrive without it immediately logging out.

    BUT, going thru the BT connection set up, and yes I am doing it correctly, it connects for maybe 10 seconds, then drops the connection.

    It's so frustrating, I need Livetraffic for my job!
Sign In or Register to comment.

Who's Online5

Maik76
Maik76
+4 Guests