DAB radio interference as soon as GO 5200 is plugged in — TomTom Community

DAB radio interference as soon as GO 5200 is plugged in

I have a dashcam fitted in my Berlingo Enterprise which works a treat whilst the DAB is running as I was told to place it in a certain area on the windscreen.

My tomtom is placed to the right of the steering when but as I plug into USB the DAB goes off? As soon as I plug the tomtom back in...…….....It goes off again?

Any help here guys as its annoying now.

Answers

  • HashtagHashtag Posts: 21 [Outstanding Wayfarer]
    Sounds like poor filtering in the TT charger. Try another USB plug.
  • DougLapDougLap Posts: 2,939 Superuser
    Hi @toe471

    I am not clear about what is happening. One thing is you should use the Tomtom Cig Connector for the Tomtom and not connect the unit to a USB socket. The power output from a USB socket is not powerful enough to run a Tomtom unit and keep it charged up as well.

    Doug
  • toe471toe471 Posts: 5 [New Seeker]

    Thanks for your replys guys!!!

    Hi @DougLap, I'm actually using the Cig connector as my main source of power to the TT but I changed the Cig connector to a twin USB allowing me to connect another source to it.

    My dashcam is connected to the main USB supply on the dash tho?
  • DougLapDougLap Posts: 2,939 Superuser
    edited September 12
    Hi @toe471

    If the twin USB connector is a Tomtom one then it should be okay but some of the Non TT connector. units which are alleged to provide the correct outputs have been shown to not work with the Tomtom units. Whilst they claim to be giving the correct output for a Tomtom they have not and the Tomtom has then gone into low power mode and turned itself off eventually.

    If the Tomtom works okay with the supplied connector then I would suspect the 3rd Party connector.

    Doug
  • toe471toe471 Posts: 5 [New Seeker]
    Hi @DougLap

    Yeh it works a treat with the twin USB connector, I know wat you mean tho as swapping them round and connecting to the USB on dashboard. My TT is dim when powered on lol

    So you think I should go back to the cig connector that TT supplied in the first place and see if that eliminates my radio distortion?
  • DougLapDougLap Posts: 2,939 Superuser
    edited September 12
    Hi @toe471

    Yup worth a try. Other than that try and place the units further apart or screen them to prevent any interference there may be between the 3 units. For example there have been instances of interference between Electronic Toll units and other Electronic devices.

    Doug
  • YamFazManYamFazMan Posts: 14,976 Superusers
    Hi
    @toe471

    Try using the Tomtom supplied cable and Tomtom supplied Power Adapter
    The Charger Adaptor and USB Cable supplied by Tomtom WILL run and charge the device at the same time

    Many 3rd party Mismatched Charger Adaptors won't run and charge the device at the same time
    See... It's not simply a power thing.....
    https://discussions.tomtom.com/en/discussion/comment/1182024/#Comment_1182024

    ATB YFM
    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > 👍 Icon
    ____________________________

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
    ____________________________
Sign In or Register to comment.

Who's Online13

Devin
Devin
Gaku1
Gaku1
Niall
Niall
YamFazMan
YamFazMan
+9 Guests