GO Premium X gets unhappy after about 2 hours of use — TomTom Community

GO Premium X gets unhappy after about 2 hours of use

ChrisOttChrisOtt Posts: 3 [Apprentice Traveler]
Hi, My Premium X after about 2 hours of use some functions stop working such as the voice directions, some items in the screen such as the route bar become empty the next exit display on the top disappears. Also the screen buttons become less responsive or slower. I have found the going to the menu and then back to the main screen sometimes fixes it, if that doesn't do it a shutdown and restart is needed then its seems to be ok for a while again. Last week I couldn't get it to shutdown easily by pressing the button on the back, the screen went blank and it was talking directions to me, I performed a power disconnect and it displayed 'No power shutting down to 8 secs' than went screen went blank (still talking to me), I powered it up again (screen still blank) than powered it off again this time it when to 1 sec. Third time it powered off and stopped talking directions. As I said its not happy. I dont really want to be going through this when I'm driving, Any suggestions would be greatly appreciated.

Best Answers

Answers

  • ChrisOttChrisOtt Posts: 3 [Apprentice Traveler]
    Thanks for you prompt and helpful reply. I will do as your reply says but I do switch the unit off each night and about 3 weeks ago a factory reset, but I will try again and see what happens. All available updates have been uploaded. When its happy , normally in the first 2-3 hrs its a very useful device then it is again after a soft reset. I live in the UK and bought it on the 08/07/2019. Thanks again Yrs. Chris
Sign In or Register to comment.

Who's Online in this Category0