New maps v10.35 available for download - Page 2 — TomTom Community

New maps v10.35 available for download



  • raesewellraesewell Posts: 133 [Supreme Navigator]
    A lesson in customer service for Tomtom, it's better to under promise and over deliver than to over promised and under deliver. Customer service 101.
  • fiskefiske Posts: 2 [Apprentice Seeker]
    edited September 2019
    Been trying to update since the update should be available. No luck.
    What is happening? I'm from Norway.
    Not possible to access or get in contact with anyone.
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    I'm sat here with a Start25 which is saying No Maps Found since I tried to update to 1035 yesterday. Keeps saying downloading items but then failing. I'd settle for getting back to the previous map - any ideas how I can do that?
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    Update - MyDrive Connect is currently saying "waiting for your device" even though it is plugged in and recognised. It is also saying Updating Device. Do I just wait?
  • NiallNiall Posts: 10,745 [Elite Voyager]

    Which map are you trying to put on your START 25?
    If it is Europe then you will need to insert a 16GB class 10 SDHC memory card as that map is now larger that the internal memory (for instalation see my guide
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    Hi Niall, it's the 1035 Europe map that appeared yesterday as an available update. I've put in a 32Gb SDHC and formatted it and plugged the start 25 back into my PC. It's gone back to the screen saying Updating Device - waiting for your device. I'd settle for a UK map if I knew how to get one. Nick
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    Hi Doug, I did all that yesterday but at that time I didn't know that I'd need to have an SDHC card in. Unfortunately now I seem to be stuck in a situation where MyDrive Connect is waiting for something from the device so won't let me get back to the home screen. Should I try uninstalling and reinstalling MyDrive Connect? Nick
  • DougLapDougLap Posts: 4,748 [Elite Voyager]
    Hi @NickHolme

    Looks like we may need the help of @VikramK to have a look at their end to see if he can help resolve this issue.

  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    Well I might be making progress, lol. I reinstalled MyDrive and it let me restart the download and gave me an option to save to SD card. Unfortunately it has just failed saying can't connect to servers, try again. So I'll keep trying and let you know. I accept that things will be busy right now. Nick
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    OK, I've gone through the process again as shown in the video and I was currently showing "downloading" but unfortunately as I've been typing it's gone to "sorry, some items weren't updated. Shall I just keep trying? Nick
  • lampardlampard Posts: 4,637 TomTom Moderator
    edited September 2019
    Hi @NickHolme

    I've made some changes in the background, please follow the steps in the public FAQ here to apply these: Re-downloading a map

    Please note: Whenever more than 1 updates are offered by MyDrive, then please update these 1 at a time, not all together. Even if the download or installation appears to stop or freeze, keep it connected for 4 hours, then check if the download has been completed.

    Regards, lampard
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    OK Lampard, I've done all that and I've currently got "Our servers are very busy right now " and "retry". Do I just keep retrying? Nick
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    OK, I've currently got a message on screen saying "Your device is not responding" . I've plugged it into a rear USB instead of a front one and we'll see what happens now. Nick
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    No, it keeps looking like it's working, saying "downloading items" and less than a minute left, and then "Updating Device" then it says "Sorry, some items weren't updated" go back to My Content page and try again. Any suggestions? Cheers Nick
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    Is there any way I can get back to the previous map? I really need my device this evening. Nick
  • lampardlampard Posts: 4,637 TomTom Moderator
    Hi NickHolme,

    I see multiple download failures for the EU map within a really short time frame. Are you sure there are no restrictions on your network connection? Apply changes to any Internet Security Software installed to allow TomTom software (MyDrive Connect) full access. Can you please try the map download using the Wired (Ethernet) connection since WiFi may work but can be slow causing a Time-Out?

    Otherwise please get in touch with our support, they'll be able to check these things for you on the call itself and assist you further. You can click on the 'Contact Us' option at the bottom of this page to do so.

    Regards, lampard
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    Thanks Lampard. I'm an administrator on a school network (100Mb/sec uncontested) so don't have any restrictions and I'm not on a wifi connection. I'll try ringing the help line. Many thanks. Nick
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    Hi DougLap, I've spoken to the helpdesk - very nice man. They are going to reload the map and then send me details by email what to do next. Unfortunately, Yahoo email has been down since 7:00 this morning and isn't back on yet so I can't receive emails - sods law. Nick
  • fiskefiske Posts: 2 [Apprentice Seeker]
    I had to reinstall MyDrive Connect to make it work for this update
  • NickHolmeNickHolme Posts: 13 [Master Traveler]
    Hi all, just to round off my contribution to this discussion, although I'm a network admin at school and should have a completely open connection, there must have been something at the broadband suppliers end (possibly firewall related) that was blocking the download. After chatting with support and having the map re-installed at their end, I tried the download here at home. It took almost 2 hours but at least it worked and I now have a fully working device again. Many thanks to all concerned. Nick
  • NavigasNavigas Posts: 11 [Legendary Explorer]
    lampard wrote: »
    Hi All,
    GO Mobile App: The maps 10.35 for the Go Mobile app, will be released a week later: on Tuesday 3/09/2019
    Regards, lampard
    I'm still waiting for a new map update of 10.35 for android GO Mobile app. You promised : on Tuesday 3/09/2019. Still no updates !
    Today is Saturday, 7/09/2019. Where is the problem.
    TomTom disappointed us again !
    Very unserious
  • papermappapermap Posts: 3 [Neophyte Traveler]
    edited September 2019
    In July tried to update my Start 25 so that quickGPsfix was up to date.I got a message that the servers were busy. Oh well did not matter, the trip went smoothly. Now I have a notice that the maps have an update I reconnected again and still see the same message. See screen shot.
    I have never had problems like this in the past and i do not know how to resolve this now. Any suggestions?


    PS edit. Yes I have kept trying.
  • LAURE123LAURE123 Posts: 1,543 [Revered Voyager]
    edited September 2019
    Hi @papermap

    For a connection problem with the message "Busy servers" often a clean installation with a fresh copy of My Drive Connect (MDC) solves the problem.

    Try to do thas:
    With your device Not connected to the PC:
    1/ Uninstall MDC, accept the removal of downloads in the popup window.
    2/ "Restart" your PC (Not Shut down or Sleep)
    3/ Download and install the last version MDC, take it here:
    - On this page, at the bottom, the green button "Download for ...":
    - In the popup window, keep ticked at least "Download updates on my computer (recommended)"
    4/ "Log in" with your email and password in MDC.
    5/ Connect your device.

This discussion has been closed.

Who's Online in this Category0