MyDrive App & Go 620 WiFi

mrpj3
mrpj3 Registered Users Posts: 132
Outstanding Explorer
edited December 2021 in Devices using Wi-Fi®
Go 620 WiFi. Android MyDrive app.
Device and phone connected via Bluetooth. Notifications for MyDrive - on. Share connection via Bluetooth on.
Plan route using app.. Send route to device. New route announced on device. All services switched on, e.g. traffic.
Question is about the small icon in the notification bar of the phone. Two cars which presume represent traffic? This is always grayed out with a cross. I would ahve thought the icon should not have the cross Watching the TomTom video on how to connect, at the end the two car icon is seen on the phone's screen without the cross.
If I swipe down to see notifications, it states to connect to Tom Tom services - I thought I was?
Any ideas. TomTom "support" are useless regarding this nd just copy and paste/read from a script when e-mailed or phoned.

Answers

  • VikramK
    VikramK Administrators Posts: 14,302
    Moderator
    Hi @mrpj3

    Could you send me the incident number of your contact with the customer service through a private message for this specific issue?

    Thanks
    VIkram
  • mrpj3
    mrpj3 Registered Users Posts: 132
    Outstanding Explorer
    Sorry, can't do that. Deleted the e-mails.
    All they were able to advise was to connect to the device, via Bluetooth, using the app.. I've done all that, numerous times. Removed the app and re-installed numerous times. Carried out a "soft" reboot of the device and even a total "factory" reset.
    The device works, the route planning in the app. works, is sent to and received by the device.
    There is the permanent traffic symbol in the phone's notification bar, greyed out with a "x"superimposed.
    In the device settings wireless (when available), Bluetooth show connected. The phone's Bluetooth shows connected to Go620. Mobile data is on as is share Bluetooth connection. Logged in to my MyDrive account on both the app. and device.
    Tried with a different phone - sam result. No traffic. Good 4G signal.
  • YamFazMan
    YamFazMan Posts: 21,143
     Superuser
    edited August 2019
    Hi
    @mrpj3

    Check... Tap 4Dot (.... Menu) --> Setting --> System... About
    Scroll down to Data connection.... What does the Device report as the Connection type ???

    ATB YFM
  • DougLap
    DougLap Posts: 10,041
    Superuser
    edited August 2019
    Hi @mrpj3

    Don't have the Android version but in the IOS version if I

    Tap Menu
    Tap System
    Tap Your Information
    If I do not have Send your location to receive Services selected then 2 cars are Greyed and have a cross. How is you're set?

    Have you got location active on phone?

    Doug
  • mrpj3
    mrpj3 Registered Users Posts: 132
    Outstanding Explorer
    edited August 2019
    Hello Doug, location is on. It's in phone settings - security, location.
    MyDrive map shows my exact location as does the device.
    YamFazMan - Bluetooth/Phone
  • mrpj3
    mrpj3 Registered Users Posts: 132
    Outstanding Explorer
    It's not really surprising that the MyDrive app. only has a 3 star rating in Playstore!
  • big
    big Posts: 1,718
    Superuser
    Are you logged in to your TomTom account on the GO 620? Settings -> MyDrive
  • mrpj3
    mrpj3 Registered Users Posts: 132
    Outstanding Explorer
    edited August 2019
    The device connects to my router via wifi and updates when avaialble.
    Yes, I am logged in to my account with both the the device and app..
    The problem is not related to the device and it's wifi connecivilty nor the navigation.
    Nor is it a Bluetooth connection problem. As stated, the device connects to my phone(s) via Bluetooth and any routes sent to the 620 using the app. works and the route is displayed on the device to select.
    The live traffic doesn't work, which I suspect is related to the greyed out and crosed cars in the phone's notification bar.
    I open notifications and the MyDrive app., swipe down on the phone's screen, a mesage display to connect my Tom Tom device - it is already connected.
    Thanks for all the replies.
  • VikramK
    VikramK Administrators Posts: 14,302
    Moderator
    Hi @mrpj3

    Could you send me the serial number of your GO 620 through a private message please?

    Thanks
    Vikram
  • mrpj3
    mrpj3 Registered Users Posts: 132
    Outstanding Explorer
    edited August 2019
    "Thanks for the serial number.

    The services look okay to me.

    Could you just do factory reset on the device and log in again and follow the pairing steps on the video as shown below:"

    I know you are trying to help, Vikram but I refer you to my post of the 19th. You really want me to do all that again?
    I think the problem lies with the app., not the device. An Android 9 issue maybe? I only have two phones to try this with, both Android 9. It's very, very unlikely that there's an issue with two separate phones.
    Yes, the services all show o.k. on the 620, and always have, but obviously not on the phone(s).
  • Ma44hew94
    Ma44hew94 Registered Users Posts: 3
    Neophyte Traveler
    I have just purchased a Go Professional 620, and have the exact same issue as you have. No matter what I have tried I cant get live traffic to work when connected to my iPhone 6S+. My friend also has a Go 520 connected to an iPhone and also has the same issue.
  • YamFazMan
    YamFazMan Posts: 21,143
     Superuser
    edited August 2019
  • Ma44hew94
    Ma44hew94 Registered Users Posts: 3
    Neophyte Traveler
    YamFazMan wrote: »

    I’m currently on iOS 12.4.1. I think this must be an iPhone compatibility issue, I have tried everything I can think of to get live traffic working but with no luck.
  • DougLap
    DougLap Posts: 10,041
    Superuser
    Hi @Ma44hew94

    Try forgetting your phone on the TTunit and the TT unit on the Phone switch them off and on and and then do the setting up out of range of your WiFi. Also when set up have you checked in Bluetooth settings that the Data setting is selected.

    In case you have not seen I here I the video on setting it up.

    https://discussions.tomtom.com/en/discussion/1034283/get-data-hands-free-calls-and-smartphone-messages-using-your-iphone-and-mydrive-app/p1?new=1

    Doug
  • Ma44hew94
    Ma44hew94 Registered Users Posts: 3
    Neophyte Traveler
    edited September 2019
    Thanks for your help, but unfortunately this hasnt worked. The issue seems very strange since a friend has the idencial problem but with his Go 520.
  • DougLap
    DougLap Posts: 10,041
    Superuser
    Hi @Ma44hew94

    Try Customer Support

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    Do not answer the questions but wait until an agent answers.

    Doug
  • Crowat
    Crowat Registered Users Posts: 1
    Apprentice Seeker
    I just purchased the 620 wifi and using it in Germany, everything connects except the live traffic even though it says my subscription is good until 2026. Is there something special i need to do? thanks
  • VikramK
    VikramK Administrators Posts: 14,302
    Moderator
    Hi @Crowat

    Welcome to the community!

    Could you try the steps on this FAQ

    Thanks/Vikram
  • DougLap
    DougLap Posts: 10,041
    Superuser
    Hi @Crowat

    What phone and IOS version have you got.

    Doug
  • mrpj3
    mrpj3 Registered Users Posts: 132
    Outstanding Explorer
    Just to finalise on my part. I've given up with this device now because of the non existence of "Live Traffic". It does work as a navigation tool but £60 would have bought that!
    I use Google Maps, their traffic works.