Go App for Android stops every now and again

Coaster1200Coaster1200 Posts: 2 [Apprentice Seeker]
For the last few months, my Go App for Android stops every now and again and I have to disable and then enable GPS on my phone. This happens sometimes while just driving but always if I turn the phone/screen off (to pop into the shops etc).
I use my phone as a sat nav to drive pre-planned routes around various locations for work. At each location, I turn the screen off and maybe make a phone call or check email etc. When I go back to the satnav app, I have to disable and re-enable the GPS or the sat nav does not follow me.
Is this something to do with the Week Number Rollover as it seemed to start around that time? Either way, any ideas what it wrong and how to fix it please?
I've reinstalled the app, completely wiped my phone and reinstalled Android and all my apps but still no joy.
I am running (unofficial) Android 8 on a Samsung S2. Originally, it worked great (from Feb) but then started playing up around April time.

Answers

  • tgoldtgold Posts: 2,057 [Supreme Pioneer]
    In the Settings menu make sure you enable Run in Background. But if that doesn't help then maybe your OS is too aggressive in closing apps. If you have enabled Android's Developer Options see if the "Don't keep activities" has been set to destroy inactive apps. Anyway this has nothing to do with the Week Number Rollover that affected nav engines in some older devices.
  • Coaster1200Coaster1200 Posts: 2 [Apprentice Seeker]
    Thanks very much for the very prompt answer.
    The Developer Option of "Don't keep activities" was not set as you describe.
    I set the app to run in the background now and it doesn't seem to have made much difference. Possibly slightly better but still the same issue cropping up. What I didn't mention before is that, quite often, the app works normally for 10 or 20 seconds after starting a route then the vehicle icon just stops moving on the map. So I have to pull over, reset the GPS and wait for TomTom to get back on track. This is in addition to is stopping "tracking" every time I use the phone for something else. This doesn't happen with G Maps and Waze so it seems to be a TT thing.
    I've now turned off Developer Options completely to see if that it messing it about. I have very few apps on my phone and none that use GPS other than those mentioned above; neither of which hold a candle to TT for me.
    Thanks again. I'll keep you posted.
Sign In or Register to comment.

Who's Online64

Elchdoktor
Elchdoktor
Kartenköner
Kartenköner
oe5psl
oe5psl
Test9
Test9
+60 Guests