Go App for Android stops every now and again — TomTom Community

Go App for Android stops every now and again

Coaster1200Coaster1200 Posts: 5 [Apprentice Traveler]
For the last few months, my Go App for Android stops every now and again and I have to disable and then enable GPS on my phone. This happens sometimes while just driving but always if I turn the phone/screen off (to pop into the shops etc).
I use my phone as a sat nav to drive pre-planned routes around various locations for work. At each location, I turn the screen off and maybe make a phone call or check email etc. When I go back to the satnav app, I have to disable and re-enable the GPS or the sat nav does not follow me.
Is this something to do with the Week Number Rollover as it seemed to start around that time? Either way, any ideas what it wrong and how to fix it please?
I've reinstalled the app, completely wiped my phone and reinstalled Android and all my apps but still no joy.
I am running (unofficial) Android 8 on a Samsung S2. Originally, it worked great (from Feb) but then started playing up around April time.


  • Coaster1200Coaster1200 Posts: 5 [Apprentice Traveler]
    Thanks very much for the very prompt answer.
    The Developer Option of "Don't keep activities" was not set as you describe.
    I set the app to run in the background now and it doesn't seem to have made much difference. Possibly slightly better but still the same issue cropping up. What I didn't mention before is that, quite often, the app works normally for 10 or 20 seconds after starting a route then the vehicle icon just stops moving on the map. So I have to pull over, reset the GPS and wait for TomTom to get back on track. This is in addition to is stopping "tracking" every time I use the phone for something else. This doesn't happen with G Maps and Waze so it seems to be a TT thing.
    I've now turned off Developer Options completely to see if that it messing it about. I have very few apps on my phone and none that use GPS other than those mentioned above; neither of which hold a candle to TT for me.
    Thanks again. I'll keep you posted.
  • Coaster1200Coaster1200 Posts: 5 [Apprentice Traveler]
    Just an update.
    Turning Developer Options off has made a huge difference - but not totally cured it. Starting TT now works almost always without having to switch GPS off then on. What regularly happens though is that the GPS signal is lost after a few tens of metres driving. I still have to turn GPS off then on again for it to work. It is much better though so thanks for the tips.
    It would be great to solve it completely but I guess it is something to do with the unofficial version of Android that I am running. Probably some sort of conflict that occurs between TT and my version of Android.
Sign In or Register to comment.

Who's Online in this Category0