Device stuck on TomTom logo — TomTom Community

Device stuck on TomTom logo

After holding start button for 30 secs i get the drums & tomtom logo then two circling arrows for about 10 seconds then it shuts off. when connected to my drive it does not show .

Comments

  • DougLapDougLap Posts: 2,934 Superuser
    Hi @phil6xy

    Does this work on your unit.

    https://discussions.tomtom.com/en/discussion/1034277/how-to-recover-your-device/p1?new=1

    The tricky bit is getting the timing right when doing the 3 Taps.

    Doug
  • phil6xyphil6xy Posts: 3 [Apprentice Seeker]
    wow a quick reply. unfortunately this does not work its just 2 circling arrows then it switches off
  • DougLapDougLap Posts: 2,934 Superuser
    Hi @phil6xy

    Looks like we need @VikramK or @lampard to have a look at the Totmotm end and see what they can suggest. It will be Monday now I am afraid.

    Doug
  • VikramKVikramK Posts: 7,964 TomTom Moderator
    Hi @phil6xy

    Welcome to the community!

    The team has made some changes in the back end.

    Just connect your device to MyDrive Connect and the jobs will process. The device might reboot.

    Once this is done, disconnect the device, perform a soft reset and check connect again for updates.

    Regards
    Vikram
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • phil6xyphil6xy Posts: 3 [Apprentice Seeker]
    Hi Vikramk
    I hold the on button for approx 30 seconds, the drums sound, then i have a small box in the middle of the screen with 2 circling arrows for approx 10 seconds then it turns off. my connect is saying not connected. I have tried several usb/micro cables, does the tomtom cable differ ?
Sign In or Register to comment.

Who's Online29

tfarabaugh
tfarabaugh
tgold
tgold
+27 Guests