"Activation failed" message — TomTom Community

"Activation failed" message

Jetlagged787Jetlagged787 Posts: 22 [Outstanding Wayfarer]
edited July 22 in TomTom Curfer
I'm trying to set up my (second hand) Curfer and get a message, "Activation failed. This Curfer is not matching the user account. Please check your login data and if you have the right Curfer."

Is this something to do with the fact that the Curfer is pre-owned? What can I do about it please?

I have not been able to find any contact details for TT customer support and would appreciate help with that too please.

Comments

  • lampardlampard Posts: 4,207 TomTom Moderator
    edited July 22
    Hi @Jetlagged787

    Please get in touch with our support with the serial number of your Curfer (start with LX as seen in the picture below) on the hardware and they'll be able to help you with this . You can click on the 'Contact Us' option at the bottom of this page to Phone/Email them.
    ee0ydqq2bp0d.png

    Regards, lampard
  • skollieskollie Posts: 2 [Apprentice Traveler]
    I'm trying to set up my Curfer and get a message, "Activation failed. This Curfer is not matching the user account. Please check your login data and if you have the right Curfer."

    I bought this new from TomTom store, and it worked perfectly on my old phone.
    Now I have upgraded to a new phone, and it will not connect. What can I do about it please?

    I called TT customer support, and they were not able to assist, and asked for a screen shot of the fault, which I cannot provide at this time.
    Please could somebody assist asap.
Sign In or Register to comment.

Who's Online28

AntonShevchuk
AntonShevchuk
Bembo
Bembo
DougLap
DougLap
Jürgen
Jürgen
kumo
kumo
lampard
lampard
nital_testing
nital_testing
scheibenklar
scheibenklar
traveler01
traveler01
+19 Guests