Support Navigation is painful — TomTom Community

Support Navigation is painful

nsthespiannsthespian Posts: 1 [New Traveler]
I need help because my content does not show the new map I purchased, your robot answers suck and there is no way to talk to an actual person that I have been able to find so far. Plus my device shows up sometimes, not others and it identifies itself differently than your site sees it (Start 62 = VIA 1625)

Comments

  • DougLapDougLap Posts: 8,910
    Superuser
    edited July 2019
    Hi @nsthespian

    There has been a problem recently that some services that have been purchased were not appearing ready for download. Tomtom advised that they had resolved the problem and were working on the backlog.

    Hopefully @VikramK or @lampard can have a look at your account and sort the matter out for you tomorrow. Keep an eye out for any comment from them here.

    Devices have been known to show up with different names but that is usually because the are same model sold under different names in different parts of the world. .Input your models first 2 characters on the following to find what model you have.

    https://uk.support.tomtom.com/app/answers/detail/a_id/9508/kw/what Tomtom model do I have

    Doug
  • VikramKVikramK Posts: 12,734 Moderator
    edited July 2019
    Hi @nsthespian

    ViA 1625 are START 62 both are same models.

    It's called VIA 1625 in USA and START 62 in Europe. ( Check which country flag is selected in MyDrive Connect)

    I think the purchase you are referring to is for the UK and ROI map, which is active on your account.

    So it should be offered for download in MyDrive Connect.

    If not, could you do a soft reset and check again please.

    Regards
    Vikram
Sign In or Register to comment.

Who's Online in this Category0