VIA won't stay connected to MyDrive long enough for update.

Just bought a VIA 1525SE and installed MyDrive Connect onto my computer. I've been attempting to bring the device up to date for a few days now, but I can't get the device to stay connected to the computer for longer than 30 seconds. The device has a full battery and so does my computer. I'm at a loss... has anyone else had this issue or anything similar? Any solutions or recommendations? I haven't found any good info on this problem elsewhere.

Best Answer

Answers

  • RoadRiderRoadRider Posts: 213 [Exalted Navigator]
    Check your (USB) power settings in Windows.
  • beebsbeebs Posts: 3 [Apprentice Traveler]
    The message I receive when the download or installation stops just says to keep the device connected.. as if I've disconnected it myself somehow. I've made sure the device is fully charge before attempting the updates and it didn't make any difference. I AM using a Surface Pro. I don't know yet if the issue is one you stated above, but I'll be trying the 'USB Selective Suspend' settings today.

    Thanks for the suggestions.
  • YamFazManYamFazMan Posts: 14,769 Superusers
    Hi
    @beebs

    Is your Surface Pro running on the Battery or Mains Power
    Is your Surface Pro connect back to the router over Wi-Fi or is it Hard-Wired back to the router

    ATB YFM

    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > 👍 Icon
    ____________________________

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
    ____________________________
  • beebsbeebs Posts: 3 [Apprentice Traveler]
    @YamFazMan

    I had to edit the registry and change the USB settings. That seemed to fix it. My device is now fully updated! Thanks for the help!!!
  • YamFazManYamFazMan Posts: 14,769 Superusers
    edited July 14
    Hi
    @beebs

    You're welcome, glad you're sorted :)
    Note... When Microsoft send another WIN 10 Update you may need to edit the registry again... The update re-sets to the the default "USB Selective Suspend" back to a hidden menu....

    ATB YFM
    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > 👍 Icon
    ____________________________

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
    ____________________________
Sign In or Register to comment.

Who's Online7

drulli
drulli
+6 Guests