Poor connections (dropping) with Rider 550, Cardo Packtalk Bold, iPhone XS and intercom — TomTom Community

Poor connections (dropping) with Rider 550, Cardo Packtalk Bold, iPhone XS and intercom

HendriksHendriks Posts: 8 [Master Traveler]
edited July 2019 in RIDER
After buying state of the art stuf it is still suffering poor connections. I made connections as explaned in the manual. Al works ok, but after making a conversation with rider A, instructions from GPS will fail. Only after rebooting it will connect. Is there someone who solved these issues?

Answers

  • RoadRiderRoadRider Posts: 565 [Revered Pioneer]
    The Cardo Packtalk Bold only works with the Bluetooth HSP profiel.

    Did you disable the A2DP on the Rider 550? (at Bluetooth setting - Headset)
  • HendriksHendriks Posts: 8 [Master Traveler]
    Thanks for the feedback,
    Yes it was al ready on HSP (low Quality). it looks like that the GPS and the bluetooth intercom ( rider A) is on the same channel.
  • jte71jte71 Posts: 10 [Legendary Explorer]
    I experience the same issue @Hendriks . You pay a lot of money but the ' performance' is poor.

    Kind regards
  • andyf001andyf001 Posts: 9 [Master Explorer]
    I assume you are using BT connection on the packtalk to talk to another headset make via BT rather than the Cardo DMC? I have no issues with my TT to GPS channel (2) on packtalk and Phone to BT channel 1 then can talk as normal via DMC to other packtalks. On recent trip had a pillion on BT to my packtalk, all still worked then as well.
  • HendriksHendriks Posts: 8 [Master Traveler]
    The thing is, i have no DMC riders in my group yet. So I use Bluetooth to communicate.

    Other strange things o cure as well. Sometimes I try to listen to my music on my IPhone.
    Then I press to the Play button on the Packtalk Bold. Then it starts playing, but I don't hear anything on my helmet, but I hear it playing thru the speaker on my phone.
    What is going?
    Other stupide things like when I get a call from someone, I can't answer it. Even when it says to be connected.
    When I make all new connections as it is ex-planed in the small manual, it won't work properly. Maybe there is someone who knows how to make this work with Tomtom 550-Packtalk Bold and IPhone XS.....


  • Fin_ILeFin_ILe Posts: 32 [Renowned Wayfarer]
    edited August 2019
    You can't.
    I have similar limitation what I'm facing, as Cardo packtalk is limited to a 2 devices (Sena has 4). As I can't connect phone, GPS and SR10 simultaneously, I want to connect my phone through TT 550, as described in the manual... But that feature doesn't exist.

  • LNorLNor Posts: 2 [Apprentice Traveler]
    Have you solved this problem? I have the same problem...
Sign In or Register to comment.

Who's Online in this Category0