Intercom and navigation — TomTom Community

Intercom and navigation

jte71jte71 Posts: 10 [Legendary Explorer]
I recently bought a Cardo Freecom 4+ set and a Rider 550. One channel we connected our phones and one channel to the Rider 550. Through the Cardo app (Android and iPhone) we can talk to each other, but I can't get figured out how I can also receive the voice from my rider 550. Am I missing something?

Kind regards,


  • ChrisHallChrisHall Posts: 256 [Exalted Navigator]
    A few suggestions:
    Voice instructions on the 550 are not muted.
    When pairing the 550, was this to BT channel 2?
    Did you roll the wheel during pairing of the 550?
    Clear all pairings on Cardo and 550, re-pair with one headset only and see if it works. Then pair the 2nd headset, then pair the phones.
    Try different pairing orders. Check the voice instructions after each change.

    The pairing can affect BT operation - my Packtalk Bold would pair but not connect to my Rider 420 if the personal hotspot on the phone was connected during the pairing process.
  • jte71jte71 Posts: 10 [Legendary Explorer]
    Hi ChrisHall,

    Thank you for the suggestions.

    The first BT channel of my Cardo is connected to my SmartPhone (android). My second BR channel is connected to my Rider 550, a GPS connection ! (turned the wheel during paring). When I ride alone, I hear the spoken instructions of the route loud and clear through my Cardo Freecom 4+. When I ride with my girlfriend, and we setup a channel through the intercom button on the Cardo app, we can talk to each other, but the Rider 550 voice disappears.

    I will try your suggestions.

    Kind regards,
  • jte71jte71 Posts: 10 [Legendary Explorer]
    edited June 2019
    So, it was a big struggle, but I cleared all pairings and managed to connect BT channel 1 to my smartphone, and BT channel 2 (GPS mode) to my Rider 550. My smartphone (mydrive installed) is connected to the Rider 550. I can listed to Spotify (good quality) or to the Rider instructions but for example if I listen to Spotify, the music is not muted when I get an instruction from my Rider. When I edit the Freecom settings and disable 'high quality (A2DP), than the music is muted when I get an instruction from my Rider but in bad quality. Make sense if you read the manual.

    Is it possible to keep high quality music, intercom and give high quality Rider instruction priority on music of intercom?

    Kind regards.

    ps: the Cadro setting Parallel audio is disabled.
  • jte71jte71 Posts: 10 [Legendary Explorer]
    Well, I got it almost working.

    Now I can listen to music and receive route information from my Rider 550. A minor thing is that the volume of the BT channel (GPS) from the Cardo is the default. So if I listen to music with let's say volume 2 and the route information comes with volume 6, the volume of both channels will be volume 6. So it seems the the BT channel where the music is presented is not muted when route information is active.

    What I did to make the magic happen is to clear bluetooth on my SmartPhone :

    Kind regards
  • jte71jte71 Posts: 10 [Legendary Explorer]
    @Hamish_Z1000 did you manage to fix you're problem?
  • jte71jte71 Posts: 10 [Legendary Explorer]
    Damn, when riding together and we setup a intercom group through the Cardo app, we can talk to each other but the route information is not coming through. So sad :angry:
  • jte71jte71 Posts: 10 [Legendary Explorer]
    If I listen to music (radio for example) through the Cardo app for Android phone I get high quality traffic information, but the music is not muted. Strange things happens here :astonished:
  • jte71jte71 Posts: 10 [Legendary Explorer]
    edited July 2019
    For now I disabled A2DP on my Rider 550 and everything works fine. I can listen to Spotify and join a intercom group. The crappy sound of the route information
    I take for granted. :s
Sign In or Register to comment.

Who's Online in this Category0