Citroen Connect Nav services not working

mjnash
mjnash Registered Users Posts: 7
Apprentice Traveler
edited August 2019 in TomTom Services
The connected services of my Citroen ConnectNav TomTom device have not been working now for a few days. My Connected services say Activated (until june 2020), but service status says Not Available. Have followed the Citroen guide to check sharing connection is active, but no luck. Any ideas?

Comments

  • Taymardog
    Taymardog Registered Users Posts: 2
    New Seeker
    Exact same issue with My Peugeot 5008. Tried Tom Tom Customer Service and they say I am not on their system (but got car last Sept and it worked till last week) and to speak to Peugeot. Tried dealer but no joy. Peugeot say all OK at their end so am piggy in the middle. Looks like a system issue somewhere - do Citroen/Peugeot monitor these forums?
  • mildenhall
    mildenhall Registered Users Posts: 42
    Legendary Explorer
    edited June 2019
    I have a Grand C4 Picasso / Space Tourer. I know you may not want to hear this but TomTom services work fine in my car.

    I have found dealers are clueless with anything but the engine parts. Try phoning Citroen Customer Services direct and say the dealer is not helpful.
  • mjnash
    mjnash Registered Users Posts: 7
    Apprentice Traveler
    I see an update is available from the Citroen web site for both the touch screen and the maps (v14). I will try these before I contact customer services. I'll let you know how it goes.
    PSA_ovip-int-firmware-version_21-07-67-32_NAC-r0_NAC_EUR_WAVE2.tar - Touchscreen
    PSA_map-eur_14.0.0-r0-NAC_EUR_WAVE2.tar - Maps
  • mjnash
    mjnash Registered Users Posts: 7
    Apprentice Traveler
    Firmware update complete, still no TomTom live services. I guess a call to the dealer is in order
  • MarkH63
    MarkH63 Registered Users Posts: 1
    Apprentice Seeker
    Exact same problem with my Peugeot 2008. I installed the service and map update, but made no difference. If anyone finds an answer please post on here as really frustrating. I'm going to see if anything on Peugeot forums and will let you know.
  • darren_austen
    darren_austen Registered Users Posts: 1
    New Traveler
    Hi All.
    I just wanted to confirm that PSA have an open case with TomTom regarding this issue. It seems to of affected many brands across the UK. PSA work close with TomTom technical department and are hoping to find a resolution very soon.
  • mjnash
    mjnash Registered Users Posts: 7
    Apprentice Traveler
    My car with Citroen Dealer Today, hes got 6 cars in over the last week with the same issue. Citroen UK deny their is an issue. He is going to escalate a technical case. But good to hear other users are now having the same issue, so its not just my car!. Darren, where did you get the info from? Do you have a PSA Case number?
  • mjnash
    mjnash Registered Users Posts: 7
    Apprentice Traveler
    So, just got the car back. Warners Citroen of Gloucester tell me Citroen UK are aware of an issue. Apparently it's restricted to areas, and I'm in an affected area. Will find out next week when I have work trip. So if you're is broke, go for a drive! They have opened a technical ticket so I will be informed when it's fixed or it anything needs doing to my car. I will update if/when I know more.
  • mjnash
    mjnash Registered Users Posts: 7
    Apprentice Traveler
    As if by Magic, today Live services are working! Guess whatever the issue was has been fixed. Would be good to know if TOMTOM were involved in any way with the fix.
  • Gazibarev
    Gazibarev Registered Users Posts: 95
    Supreme Navigator
    I do not know if there is a connection with the case but I also have no gprs connection. Today I had about 2 hours and then disappeared again. I have been experiencing difficulties for 2 months but the last 2 weeks have no GPRS connection. .. device is 6250 professional.
  • mjnash
    mjnash Registered Users Posts: 7
    Apprentice Traveler
    Update from my Citroen dealer, Issue was 100% with TOMTOM. Server Failure apparently that took 2 weeks to fix!
  • Roaring_30
    Roaring_30 Registered Users Posts: 2
    New Seeker
    This problem has just returned on my Citroen C4 Picasso. It first happened at the time of this discussion but disappeared when it was resolved for the other users but now its back!
    It appeared that previously it was a TomTom server issue and it took several weeks to resolve.
    Has anyone else experienced this problem?
  • Roaring_30
    Roaring_30 Registered Users Posts: 2
    New Seeker
    Yesterday no Tomtom Traffic but today it has returned so I guess it was a server error again.