VIA 53 only loads up halfway then goes back to beginning — TomTom Community

VIA 53 only loads up halfway then goes back to beginning

Press and hold the On/Off button. Do not release the On/Off button when the device restarts with a drum sound. Instead, keep holding the On/Off button until the device shows a black screen with white text. Only release the On/Off button when you see that screen. This can take 10 seconds or longer.

Image

While the black screen with white text is displayed, press and fully release the On/Off button 3 times, quite quickly as in "1-2-3". Getting this timing right is one of the critical steps of this process.
The screen goes black, and then after a few seconds the device reboots into recovery mode. It shows a screen with a spinning cogwheel or wheel depending on which device you have.

Image Image

If you do not see a spinning cogwheel or wheel, turn off your device and start again from step 6.

Quickly connect the USB cable to your navigation device. You need to connect the cable while the spinning cogwheel or wheel is shown.

As soon as your device is connected to the computer MyDrive Connect starts restoring the TomTom software on your device.

Do not disconnect your device.

Image

Image
You can check the progress in MyDrive Connect.

Image

Critical: The recovery process can take between 5 and 30 minutes, depending on your internet connection. Do not disconnect your device from your computer during the recovery process or you might corrupt the device. Even when 100% of the download is done, leave your device connected.

Wait for your navigation device to restart.
Sign In or Register to comment.

Who's Online61

ajinugr
ajinugr
garycourtney
garycourtney
lampard
lampard
NancyZ
NancyZ
Palferman
Palferman
robertmcw
robertmcw
sonnenblume468
sonnenblume468
+54 Guests