GO 620 Wont Connect to WiFi or Personal Hotspot — TomTom Community

GO 620 Wont Connect to WiFi or Personal Hotspot

My Go 620 has suddenly decided not to connect to my home WiFi or the Personal Hotspot on my iPhone XS Max. This has been a very problematic GPS. Usually the Traffic shows Service unavailable IF and when it's connected to my iPhone but that's rare. TomTom Support in the past has NOT been very helpful in getting me back up... and I'm about to leave TomTom after 14 years of buying GPS units. Any one else having problems connecting to their phone (even Bluetooth is problematic) or WiFi on the 620?

Comments

  • bigbig Posts: 1,552 Superuser
    Sometimes there are problems to phones, especially iPhones, but most of those problems can be solved by deleting the pairings on both the phone and the GPS and then re-pairing.Occasionally a new iOS release will break things for a while.

    But if you are having problems with both WiFi and Bluetooth, especially since they've worked before, sounds a lot like a hardware problem (e.g. a loose antenna wire) to me!

    Will it connect to other WiFi access points successfully?
  • DGholsonDGholson Posts: 4 [Master Traveler]
    Thanks for replying big. I just turned it on while in my house... and it instantly connects to WiFi, Traffic and MyDrive. BUT... I'm in my house so that's not very useful. It's when I'm in my car and trying to get it to connect via Bluetooth or Personal Hotspot that the Traffic shows Unavailable, etc. Sometimes I have to do a Reset on the unit and then pray that the Traffic is going to work. TomTom Traffic is the BEST and I've known it for years. It's uncanny how accurate it is and how it has saved me from traffic backups, but now I just don't know about it if the Traffic is either NOT going to connect, or connect for awhile and then just stop working. I'd really like to use the Bluetooth connect over my phone but it's just wonky at times. Seems like the 620 connects to my home WiFi when I start the car in my garage and then tries to switch over to the Bluetooth on my phone once I drive away. And that's problematic it seems.
  • bigbig Posts: 1,552 Superuser
    A couple of years ago I recall people mentioning the switchover from WiFi to bluetooth was a problem but I haven't heard that since then. I don't have a problem with that and one setup I have is nearly identical to yours. (Of course, me saying this doesn't solve YOUR problem, of course.)

    I do find that every now and then I don't have traffic and notice the mydrive app on the phone is unresponsive. I force quit the app and start it again, then all is good. Just takes two seconds. (If you're not sure how to do this, see https://support.apple.com/en-us/HT201330 )

    Rarely (once every few months) the solution is to restart the 620. The other times -- every other week or so -- the force quit thing is the solution.

    I guess if you're sure it's the switch-over from WiFi to Bluetooth and nothing else works you can always wait till you're out of WiFi range before turning on the 620 (but, yeah, not really how you wanna work it).
Sign In or Register to comment.

Who's Online42

bastle
bastle
Bembo
Bembo
Elchdoktor
Elchdoktor
Justyna
Justyna
Jürgen
Jürgen
newlandman
newlandman
PrivateerUK
PrivateerUK
Serhan
Serhan
will_nicol
will_nicol
+33 Guests