My brand new TomTom GO Premium X says Traffic and Speed Camera updates are going to "Expire" soon

iPaulis
iPaulis Registered Users Posts: 2
Apprentice Traveler
edited December 2021 in Devices using Wi-Fi®
I have just bought a TomTom GO Premium X to replace my old GO 930 (both devices are registered in my account). However, from the menu, if I select System->About, it says that both Traffic and Speed Camera Updates are going to "Expire" soon, and tells me to renew these services by going to the shop and paying more money. But the TomTom GO Premium X is supposed to have Lifetime Traffic and Lifetime Speed Camera Updates. GPRS also seems to be disconnected, but that might be normal, I don't know how it is supposed to be.
So what's going on, please? I just received it today and this is my first experience with this new device, and already the first thing I have to do is contact to ask for some kind of support.
Surely it shouldn't be saying these services are going to expire, since they should both be active for the "Lifetime" of the device? Please, fix this.
Tagged:

Best Answer

  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    Answer ✓
    Hi @iPaulis

    Welcome to the community!

    Made some changes in the backend.

    If you could do a soft reset, and check for updates please..

    Regards
    Vikram

Answers

  • YamFazMan
    YamFazMan Posts: 20,797
    Superuser
    edited June 2019
    Hi
    @iPaulis

    @VikramK or @lampard the Tomtom Forum Moderators
    Will probably check/refresh your account status Tomorrow

    ATB YFM
  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    Answer ✓
    Hi @iPaulis

    Welcome to the community!

    Made some changes in the backend.

    If you could do a soft reset, and check for updates please..

    Regards
    Vikram
  • iPaulis
    iPaulis Registered Users Posts: 2
    Apprentice Traveler
    VikramK wrote: »
    Hi @iPaulis

    Welcome to the community!

    Made some changes in the backend.

    If you could do a soft reset, and check for updates please..

    Regards
    Vikram

    Thank you for the quick response and for helping me with this problem. I just checked and everything seems to be working as expected now. Thank you very much :)
  • dowland
    dowland Registered Users Posts: 5
    Master Traveler
    Hi @VikramK ,

    I have the same issue with my Go Premium X, are you able to assist at all please?

    Many thanks

    Richard
  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    @dowland

    I have asked the team to fix the subscription on your account.

    You just have to do a soft reset and log in to you device. The subscription should be okay then.

    Regards
    Vikram
  • mkr030
    mkr030 Registered Users Posts: 6
    Master Explorer
    I have bought a TomTom GO 6200 .and Traffic is not working . I got this message even the services is activated ( we are having trouble accessing Tom Tom services please try again later ) and I tried to reset the device many times but still not working!! .
  • miketorcy
    miketorcy Posts: 3,558
    Superuser
    Try factory reset.
  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    HI @mkr030

    Does the GPRS status say- Connected?


    Main menu- Settings- System-About- GPRS staus

    Regards
    Vikram

  • mkr030
    mkr030 Registered Users Posts: 6
    Master Explorer
    Hi Vikramk
    Yes it does
  • VikramK
    VikramK Administrators Posts: 13,745
    Moderator
    Hi @mkr030

    I don't find any issues with the services in the back end.

    Did you already try the factory reset?

    Regards
    Vikram
  • mkr030
    mkr030 Registered Users Posts: 6
    Master Explorer
    Yes, I tried the factory reset, and it doesn’t work!!
This discussion has been closed.