Not downloading updates

jimcor
jimcor Registered Users Posts: 10
Master Traveler
edited June 2019 in MyDrive Connect
When I connect and click on Update, it shows ''Downloading Items" & "Getting Ready" but nothing happens. Anyone know what I'm doing wrong?

Comments

  • DougLap
    DougLap Posts: 10,024
    Superuser
    Hi @jimcor

    What Tomtom unit have you got.

    Doug
  • jimcor
    jimcor Registered Users Posts: 10
    Master Traveler
    it's a 4eq50, I think.
  • DougLap
    DougLap Posts: 10,024
    Superuser
    Hi @jimcor

    What are the fist two characters of the serial number?

    Doug
  • jimcor
    jimcor Registered Users Posts: 10
    Master Traveler
    BP?
  • DougLap
    DougLap Posts: 10,024
    Superuser
    edited June 2019
    Hi @jimcor

    Your device is a TomTom Start 25 with 8GB memory and it updates through MyDrive Connect.
    Your device is fully supported through phone and email.

    Have you downloaded the MyDrive Connect software, not Tomtom Home. and logged into your account.

    Doug
  • jimcor
    jimcor Registered Users Posts: 10
    Master Traveler
    Thanks Doug. I did and have and, funny enough, after turning everything on and off multiple times, it has begun to download the updates! Technology never fails to surprise me. Thanks again.
  • DougLap
    DougLap Posts: 10,024
    Superuser
    Hi @jimcor

    Glad you seem to be getting sorted. Can I suggest that in future you do all the updates one item at a time and when finished you do a Soft Reset.

    Doug
  • jkahanamoku
    jkahanamoku Registered Users Posts: 5
    Master Explorer
    TomTom Go Live 1005, your server is doing the same with this... "preparing to download" and preparing so long it completely times out. Been trying for 3 days now. Tried switching off and on of everything. Checked it's logged in and your server sees the device, but won't commence download. What's going on at your end? Never, ever had this issue before.
  • Vexed
    Vexed Registered Users Posts: 2
    Apprentice Traveler
    Exactly my issue with Go Live 825 Its been like this for a week now and there is a major map update pending
  • lampard
    lampard Administrators Posts: 6,061
    Moderator
    Hi @Vexed

    Welcome to the Community! I see that your latest map update for UK & ROI map (version 10.40) is successfully updated on your device.

    If this happens next time, my first advice is to just do a soft reset and connect it back again to MyDrive.

    Regards, lampard
  • TomFinn
    TomFinn Registered Users Posts: 1
    New Seeker
    TomTon Start 20. Same issues as above. Navigator connects to PC and MyDrive, and it starts "preparing". Never any download and have tried for days. Restarting MyDrive or soft booting the navigator dont help. Download size 60kB which is a joke. The problem must be with TomTom server...
  • SwallownAmazon
    SwallownAmazon Registered Users Posts: 2
    New Seeker
    TomFinn wrote: »
    TomTon Start 20. Same issues as above. Navigator connects to PC and MyDrive, and it starts "preparing". Never any download and have tried for days. Restarting MyDrive or soft booting the navigator dont help. Download size 60kB which is a joke. The problem must be with TomTom server...

    I have been trying to download updates since before Christmas; re-starting device and computer multiple times does nothing. TomTom units great at keeping you on the road - customer service? USELESS
  • DougLap
    DougLap Posts: 10,024
    Superuser
    Hi @SwallownAmazon

    What are th first 2 characters of the Serial number of your device.

    Doug
  • SwallownAmazon
    SwallownAmazon Registered Users Posts: 2
    New Seeker
    I have now managed to download the updates after I received a reply to the last of my three separate emails less than 15 minutes after posting my comment here; coincidence or what? However, It took me about 35 minutes to follow the instructions about modifications to my computer and nearly three hours to download the updates.
  • DougLap
    DougLap Posts: 10,024
    Superuser
    edited November 2020
    Hi @SwallownAmazon

    Glad you are sorted. Unlikely o be coincidence as this is a Customer Forum where the vast majority of contributors are Customers. Only a handful of TT employees look in from time to time

    Doug
  • Unorthodoxy
    Unorthodoxy Registered Users Posts: 1
    New Seeker
    I'm having the same problem. 3+ days and no download. Device is a Via 135.
  • DougLap
    DougLap Posts: 10,024
    Superuser
    Hi @Unorthodoxy

    What are you seeing. Is it saying Servers Busy for example.

    Doug
  • Kezrob23
    Kezrob23 Registered Users Posts: 1
    Novice Seeker
    I am having the same issue on a via 1500.
    It says preparing, then downloading, then stops and says there was a problem.
    I've heard back from TomTom, they said they reset my account and I could now download without any problems but it's still happening.
    Device alternates between having no maps installed or just NZ maps, depending on how it feels at the time.
    I have sent another message, but took 5 days to get an answer the first time so not hopeful of getting help anytime soon :(
  • VikingSGO
    VikingSGO Registered Users Posts: 2
    New Seeker
    Last update almost killed my device. after several attempts and several hours connected it finally went ahead and installed all back. I had won the battle.
    Now again it is refusing to just work "server too busy" or alike but not able to do basic updates... This is why I not yet did replace my TomTom with a new one... no longer confidence in this brand... I will take a Waze paid service over this now anyday!
  • YamFazMan
    YamFazMan Posts: 21,132
     Superuser
    Hi
    @VikingSGO
    Welcome to the site....
    Firstly Try....
    Disconnect your Tomtom device....
    (Do not Reconnect your device until instructed)
    Logout of MyDrive Connect....
    From the Power menu 'Restart' your PC (NOT Turn it Off 'n' On again)....
    Run MyDrive Connect & Login... Connect & Start your device....
    __________________________

    If you are still having problems with MyDrive Connect... I find deleting the "HOME3" and the "MyDrive Connect" folders in the MyDrive Connect Program will usually bring MyDrive Connect back to life...
    See... https://discussions.tomtom.com/en/discussion/comment/1704775/#Comment_1704775

    Stay Safe... ATB YFM