Carminat Stuck in a loop of hourglass screens after last update — TomTom Community

Carminat Stuck in a loop of hourglass screens after last update

tommym100tommym100 Posts: 4 [Apprentice Traveler]
I have a 2010 Renault Megane with built in TomTom Carminat which I recently updated. When I put my updated SD card into the device it appeared to update the firmware on the console, all successfully by the looks of it, it then started an infinite loop of hourglass screens.

I have followed instructions on many forms on how to fix this issue, firstly was restoring my SD card via TTHome, I deleted the loopdir folder, I have made a manual backup of my SD, formatted it, put it back in to the device then pc (a new loopdir file is created). I have then tried both copying the old files back on to the SD card and also using manage my device in TTHome to add maps etc back but with no joy.

Is there anything else I can try, or any way to re-download the maps files etc from TomTom as oppossed to using the backups on my pc (incase they are what is corrupt).

Any help or advice would be very much appreciated.


Best Answer


  • VikramKVikramK Posts: 8,589 TomTom Moderator
    Hi @tommym100

    Welcome to the community!

    Could you please try the steps on the FAQ below:

  • tommym100tommym100 Posts: 4 [Apprentice Traveler]
    Hi @VikramK

    I tried these steps yesterday as I found them on another forum, but I had no luck. The only thing I could not replicate in the steps was step 5, reloading the maps etc. When I plugged the SD card back into my laptop, it only gave me the option to update once voice, that was all that was in the list, once I done this there were no more updates available. The only way I could add maps back to the sd card was to go to manage my device and restore them from the PC or to copy them files back from the backup. Should this be the case or should my device have found maps in the update process?

  • tommym100tommym100 Posts: 4 [Apprentice Traveler]
    Thanks you @VikramK , I will that again when I am home this evening.

  • tommym100tommym100 Posts: 4 [Apprentice Traveler]
    @VikramK I was able to get it working this time by formatting the SD, putting it in the nav, back in the PC and this time it gave me the option to install maps from my account. I done this then it worked as expected.

    I appreciate your help!

Sign In or Register to comment.

Who's Online9

9 Guests