GO 5000 will not connect for connect — TomTom Community

GO 5000 will not connect for connect

the go 5000 will not connect to any computer to update.
I am able to successfully connect other tom tom devices using the same cables/usb port/computer.
in the go 5000 menu, it says no internet and my drive connect says not connected.
I have tried the following to force this go 5000 to connect;

reset the device.
tried different cables and connections, usb, thru the cradle and the multi pin tom tom connector.
tried different cables and ports on computers.
tried two different computers, win 7 and win 10

how do I force this go 5000 to connect to anything to update? Can I download updates to micro sd and transfer to the go 5000?

Best Answer


  • ZsoltZsolt Posts: 36,011
    You won't be able to download to a memory card and transfer. Nor would be able to do via the cradle. Why you connect the cable into the GO 5000 directly (in its USB port on the device), does it feel loose or does is wobble? In case yes, maybe the USB port on the device is broken.

    Also another question: When you fully charge the battery and disconnect the charger, how long does it hold charge?
  • audible86audible86 Posts: 4 [Apprentice Traveler]
    edited June 2019
    I tried a number of cables, a mini usb and two of the multi pin cables, one that came with the unit and one from my older tom tom, a GO 1005?

    In any case, the go 5000 reacts to all of the cable connections, in that it prompts the auto 15 seconds shut down when I unplug them for example.

    Not sure how long it holds charge for. I've only run it for 15 minutes or so off the cable and its fine for that amount of time at least.
  • ZsoltZsolt Posts: 36,011
    edited June 2019
    The GO 1005 is not exactly compatible with the GO 5000, so that cable wouldn't work for data transfer, as far as I recall. You would need to use the micro USB on the bottom of it (if I'm correct, had a GO 5000 years ago).

    Try to keep it connected to the PC, with MyDrive Connect running, then press and hold the ON button, all the way till you hear the drum roll.
  • YamFazManYamFazMan Posts: 19,211
    edited June 2019
    Re : GO 5000 .... Fully wired (Data & Power) Micro USB Lead




  • audible86audible86 Posts: 4 [Apprentice Traveler]
    edited June 2019
    Zsolt wrote: »

    Try to keep it connected to the PC, with MyDrive Connect running, then press and hold the ON button, all the way till you hear the drum roll.

    Ok, so I turned the go 5000 off, using the hold the power button then selecting "turn off".
    The moment I connect it to the PC via the Micro USB, it boots the tom tom up. I also tried turning it off while connected to the PC, leaving it for 30 secs, then holding power button until I hear the "tom toms".

    Still no joy in connecting to the internet.

    Oh, for the record, I also shut down my AV/firewall software, no effect.

    I also left the Go 5000/5100 powered up without being connected to anything for 30 minutes and it ran fine from the internal battery which is very unusual as Tom tom internal batteries usually fail after a few months.

    I also noticed that my go 5000, is a GO 5100, I think. Tom tom my drive connect identifies it as a Go 5000 the correct serial number, but in the tom tom menu/settings/help, it identifies the unit as a GO 5100.

    Last time the Go 5000/5100 connected to my drive was 15/11/2018, Aust map v1015.9100 installed and application version 18.200.0018.311 (02/08/2018)
    if that helps any.

    YamFazMan wrote: »
    Re : GO 5000 .... Fully wired (Data & Power) Micro USB Lead

    Oh right, Micro, not Mini. So many different connection types. Technically, it's the USB plug that fits. But thanks for the correct term definition.

    Oh and, nice choice of ride the Fazer's. I'm a VFR rider myself. :-)

  • audible86audible86 Posts: 4 [Apprentice Traveler]
    Ah hah!
    That did it. Thanks for that DougLap.

    The Go 5100 was showing as an "other" device in Device manager. I uninstalled, re installed and then It showed as an Tomtom Go 5100 under Network adaptors and connected automatically to my drive connect.

    Downloading updates now.
  • DougLapDougLap Posts: 7,692
    Hi @audible86

    Pleased to hear you are working again.

  • wmanzionewmanzione Posts: 3 [Apprentice Seeker]
    Solved it too. In my case it was the USB cable: i used one coming from another device (an electronic cigarette). Tried every port on my pc. Eventually i used a cable from an old Nokia phone: bingo!
Sign In or Register to comment.

Who's Online in this Category0