GO 620 Wifi freezes after drum roll at start up — TomTom Community

GO 620 Wifi freezes after drum roll at start up

After I downloaded (via wifi) USA maps (6.? Gb's) onto GO 620 WiFi, it freezes after drum roll and white line has reached RHS. Nothing else happens. Have gone into system restore and connected to MD at crucial point and clicked start button 3 times and connected to pc (Win 10). MD states that restore is happening. Have tried this restore many times and same thing happens. Cannot get "into" GO 620 via MD to remove download and start again ...Have searched FAQ's and other internet sources, and cannot get any answers. Don't know what else to do. Help! Leaving for USA on Tuesday 4th June, 2019! Is there any way to factory reset and start all over again with new maps etc?

Best Answer

Answers

  • TassieDave1TassieDave1 Posts: 7 [New Seeker]
    Reading some posts (particularly from DougLap) I may have inadvertently downloaded USA map into internal memory instead of SD card..If this is the case, then I guess the internal memory is overloaded to the point that it cannot start!..What would be the fix for this, please? Anyone, please help.
  • DougLapDougLap Posts: 7,285
    Superuser
    Hi @TassieDave1

    It is the sort of thing that happens when the memory gets too full. Have you tried the Soft Reset. ie fully charge then turn the unit on and when it has stopped loading hold the ON/OFF button down for about 20 seconds until the drum roll sound then let the button go. I would try this several times it may suddenly start at which point go into Settings/Map and select Delete the USA map.The unit should not load the map and totally fill the memory.

    All the best

    Doug
  • TassieDave1TassieDave1 Posts: 7 [New Seeker]
    edited May 2019
    Hi DougLap,
    Yes, I did try that -many times. Eventually it suddenly worked, so immediately deleted the USA maps! Also, it required a software update, which I thought was a good idea, so did that (with unit powered from the mains charger). After updating it rebooted itself - two separate drum rolls but sadly it froze again. Couldn't turn off, so went through Soft Reset plus extra time so that black screen with white writing came up. Did not connect to pc, but instead pushed on/off button once and screen went black; presumably went off.
    Can I get into the GO 620 software somehow to conduct a factory reset?
    Thanks for your help so far. Much appreciated. Best, Dave
    PS Noticed when deleting USA map that not only do I have Oceania maps but South East Asia too! Very strange - presume I can delete the South East Asia as I don't need it. Thanks, again.
  • DougLapDougLap Posts: 7,285
    Superuser
    edited May 2019
    HI @TassieDave1

    You can only do a factory reset if you can start the GO620 and can use the menu system.and you do the following.

    Tap menu
    Tap Settings
    Tap System
    Tap Reset Device
    Tap Okay.

    Now this returns it to how it came out of the box for you to originally set up except it will have the latest Operating Software, if you have updated it since you got it, and the maps you have on it are untouched.

    If you have been saving Favourites (My Places) on you GO620 they should have synced back to your account and you can see them if you go to the MyDrive Website and log in. Any Poi and Route files you have loaded via MyDrive will also be on your account. When you finish th e reset when you connect it t the Wifi it will sync all this data back onto the unit. Any routes you have created on the unit and saved to My Routes will be lost except those which were recorded buy the unit. You can export those via a Micro SD card which can be very small as routes are usually small files.

    Just out of curiosity what size and make of Micro Sd card have you got in the unit.

    Finally when you have done the reset and it is working do a Soft Reset and also do the same after each update you do or map you load in future.

    I have flagged this to @VikramK to see if he can see anything in their logs of the activity on your unit and also if there are any setting changes they can do to unblock any problems.

    Lets know how you get on in the mean time there are a couple of things I will suggest you do once this is all sorted out in the meantime do not delete all maps on the Internal memory and what map were you using when this problem started.

    Hope that helps

    Doug
  • TassieDave1TassieDave1 Posts: 7 [New Seeker]
    Thanks for response - I will try this after the GO620 has recharged. (Obviously on stand by when screen went blank/black last night and battery was flat). And if I can get back to menu!

    Using a 16Gb Lexar C10/UHS-1 sd card - soft reset after downloading maps didn't happen. First freeze occurred when the current map was Oceania, but after I had downloaded USA map - then again later it froze after I'd been entering locations into My Places on the USA map.

    Seems to happen at the end of the start up sequence (drum roll and loading indicator at bottom of screen reaches RHS of screen, then no more activity. Have even left it at that position for more than an hour.

    Thanks for your positive replies. Cheers, Dave
  • TassieDave1TassieDave1 Posts: 7 [New Seeker]
    After many attempts to reboot GO620 I read in a Techwalla post to reboot after taking out sd card - I did this and it started correctly - immediately asked for software update, so that is happening as I write. It is updating to internal memory only. Ithas now started correctly; asking for the usual TomTom permissions etc and now back to main screen!!
    Obviously SD card is corrupted or full.

    I have opened the sd card on my pc and there are 8 files marked TomTom 000>007, but I don't know what programme is used to open them. The properties of the card show that it is FAT32 system; used space 15,720,579 bytes; free space 0 bytes! So card is full!
    I have no idea what is on the card and am wondering if I formatted the SD card to clear it, I may be able to use it again?

    I have checked in menu>settings>system>about in GO620 and see there is 11.00GB free space in internal memory with two maps installed - Oceania v1025.9378 and Southeast Asia with same version number as above, both released 01/2019.

    There is also the option to format the memory card, which I assume would be the external one and not the internal?

    At this stage, I am rather loath to reset device, and feel unwilling to turn off the device but welcome any further suggestions you can offer. Thank you so much.

    If a new card is required can you recommend a make and size, please?

    Regards, Dave from Tassie
  • TassieDave1TassieDave1 Posts: 7 [New Seeker]
    Hi again DougLap,
    I also cannot get into My Drive. Have installed and uninstalled, several times but cannot even find the unit in Device Manager>Network Adapters. When I plug unit into pc, I hear a sound but nothing comes up on screens of pc or unit. Yes, I am plugging direct into a pc USB port, and yes I am using TomTom supplied cable. I do hate this technical stuff!
    Thanks again
    Cheers TassieDave
  • TassieDave1TassieDave1 Posts: 7 [New Seeker]
    Hi DougLap
    Firstly, thank you so very much for your time. I'm so pleased I'm up and running! I'm formatting the SD card as I write (slow one, as you suggested).

    Thank you too for the MyDrive info. In the settings of the unit it states that I'm connected to MD...so I'll accept that.

    Think the two problems starting this problem were that although I had unit connected to pc (for charging only) when downloading large US map via wifi, it wasn't being charged (?) enough - anyway - the other being the too full sd card., Later, I'll download that US map onto SD Card. Seems all My Places are intact!

    Thanks so much and I hope that anyone else reading this finds all your info as useful as I have. All the very best, mate. Cheers Dave from Tassie!
  • DougLapDougLap Posts: 7,285
    Superuser
    HI Dave

    You are welcome. Re the unit and charging when you are doing any updating when not connected to a PC you get a Screen shot saying connect to a power source. You can get a mains charger or if you have a smart phone like an Apple you may find the mains charger plug for that will work. Be very careful to check the power out put of the plug corresponds to the Poor output shown on the TT cig socket plug..

    One little tip. If you only have the European map on your unit do yourself a favour and download the Venezuela Map. It is only 29mb and will go on your Internal memory alongside the European map. Now if you have a problem during the update of the European map and as a result it does not work properly and the map fails then the Venezuela map will be there to help your unit start properly and you can sort the problem out.

    Doug

    ATB

    Doug
Sign In or Register to comment.

Who's Online in this Category0