Navcore software

XLP99
XLP99 Registered Users Posts: 6
Master Traveler
edited December 2021 in Devices using MyDrive Connect
So it seems the problem with my start 25 sat nav not updating is that the navcore update won't download onto my device, hence being unable to update my maps and constantly getting the "no maps found" result.

How do I get this update? Everything I try fails.

Answers

  • Niall
    Niall Posts: 11,140
    Superuser
    @XLP99

    Try contacting customer services, as the problem maybe their end ;

    United Kingdom
    02079 490 132
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • XLP99
    XLP99 Registered Users Posts: 6
    Master Traveler
    Thanks Niall. Have spent far too many hours trying to update this bloody device for my sister!!!
  • lampard
    lampard Administrators Posts: 6,061
    Moderator
    Hi @XLP99

    I can see that the latest map of Western Europe is installed on your device with the latest navcore application yesterday. Hope your issue is resolved!

    Regards, lampard
  • XLP99
    XLP99 Registered Users Posts: 6
    Master Traveler
    Thanks everyone for your help and sharing.

    Spent a lot of last night searching in the forum and discovered that there was a new version of My Drive Connect out yesterday. So I uninstalled my version - which was only downloaded 2 weeks ago - and installed the newer version. Lo and behold, my satnav updated! Sometimes it helps to be stubborn and not give up!

    If I wasn't on the forum, I'd still be trying to get it to update! Did email tomtom last night and got a response this morning - with links to try. Anyway, hope this helps others out.

    And thanks @lampard. Am crossing fingers that my sister wont have any problems when she uses it now. (She's the main user.)