New version of MyDrive Connect available for download! - Page 2 — TomTom Community

New version of MyDrive Connect available for download!

2»

Comments

  • ciphercipher Posts: 2 [Apprentice Seeker]
    I have a Start 60 (VE serial, MyDrive Connect) with lifetime maps, which was happily updated in its early years. Within the past couple of years I started facing problems updating it via the MDC application. In particular, it is either not recognised at all, or it exhibits disconnections at random intervals, hence interrupting the update process.

    Last update attempt was a nightmare. I tried it on multiple machines:
    1. Windows 10 (1903) Core2Duo Dell laptop with USB2 ports only. Never managed to recognise it.
    2. Windows 10 (1903) i5 Asus laptop with both USB3 and USB2 ports. It was recognised only when connected to one of its USB3 ports and managed to update the firmware in this way. Maps were downloaded, but suddenly the Start 60 was not recognised by the MDC app and could therefore not update its maps.
    3. Windows 10 (1903) i5 desktop with both USB3 and USB2 ports. I literally tried every single port, but it never recognised it.
    4. MacBook Pro (early 2011, macOS Sierra 10.12.6) with USB2 ports. It managed to recognise it only once, downloaded the maps, but failed to connect to it when maps were to be updated.
    5. Windows 10 (1903) i5 desktop with both USB3 and USB2 ports (let's call it "desktop 2"). Two of its USB2 ports worked almost all the time. Even when one of them started to misbehave, plugging the Start 60 into the other port would almost always work. Thanks to this PC I managed to successfully update the maps.

    Needless to say that I also came across server busy/inaccessible errors, that made things even worse. Well, if several users have to download a map multiple times before a successful update (like it happened to me), it consumes significant bandwidth.

    I searched in online help and forums and made sure I followed the suggested way of performing the update, i.e.:
    • Original cable plugged directly into the Start 60 and the computer.
    • Uninstalled / reinstalled MDC.
    • Restarted computers.
    • Soft reset the Start 60.
    • Disabled antivirus.
    • Disabled power management features for preventing the computer from going to sleep and/or USB power management.

    Under Windows 10, the most common error was the "USB device not recognised" and in the Device manager > USB controllers it showed as:
    Unknown USB Device (Device Descriptor Request Failed)

    On desktop 2 (the one that worked), it appeared in Device manager > Network adapters as:
    Remote NDIS Compatible Device

    The MDC versions used were as follows:
    MDC (macOS Sierra 10.12.6): 4.2.5.3779
    MDC (Windows 10 1903): 4.2.5.3770

    The Start 60 now has the following loaded on it:
    Firmware version: 18.203.0026.311 (05/04/2019)
    Maps: Europe, v1030.9581 (04/2019)

    I am very disappointed by the poor quality of the MDC software, which also seems to get worse with time. Effectively it more or less cancels out the "lifetime maps" feature, for a machine that has not reached its end of life yet.
  • YamFazManYamFazMan Posts: 14,968 Superusers
    edited September 11
    Hi


    On the rare occasions I have a problem with myDrive I use either.....

    Option... (1) Delete MyDrive Connect using the free version of Revo Uninstaller
    OR
    Option... (2) Delete the Home3 and the Mydrive Connect Folder
    ___________________________

    Option…(1) If you're using a Windows PC... Delete MyDrive Connect using the free version of Revo Uninstaller
    If you're using a Mac... Surely there must be a Deep Clean Un-installer Program available for a Mac ???
    Download & install the free version of Revo Uninstaller
    Here...https://www.revouninstaller.com/revo_uninstaller_free_download.html
    Revo first uninstalls the Program... Then scans and removes all of the left over files a normal uninstall leaves behind
    Video using the Revo Uninstaller
    The Free & Pro Versions use the same process....

    (1)... Uninstall MyDrive Connect Using the Revo Uninstaller
    (2)... Clear your browsers cache (Optional, but I find it helps)
    (3)... Restart your PC (Not Turn Off & Turn On again)
    Reinstall MyDrive Connnect (Important... Without your device connected)
    Connect & Turn on your device... Login to MyDrive Connect
    ___________________________
    ___________________________

    Option... (2) Delete the Home3 and the Mydrive Connect Folder
    If you have installed MyDrive Connect to the default location using Windows 10
    It's located here... C:\Users\"Your Computers Name goes here"\AppData\Local\TomTom\

    If you delete the Home3 and the Mydrive Connect Folder it removes the Cache Folders & Contents, Prefs.ini, cookies.ini. Logs and Configuration.xml files and and force a reload of the Cache Data
    A new Home3 and MyDrive Connect and their contents are created fresh the next time you use MyDrive Connect
    You will have to login again, as if you had just installed MyDrive Connect
    ___________________________

    Method…..
    (1)... Disconnect the SatNav from the PC and reset it by holding down the off button for 20 secs until you hear the ‘drumbeat’ release the button
    (2)... Press keys ‘Windows’ + ‘R’… To Open the ‘Run’ box
    (3)... Type into the ‘Run’ box %localappdata%/TomTom
    (4)… Press Enter... A new window opens, delete the Home3 and MyDrive Connect folders
    (5)... Close all windows
    (6)... Turn on the SatNav and reconnect it to the PC and open ‘My Drive Connect’
    You will have to login again, as if you had just installed MyDrive Connect

    ATB YFM
    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > 👍 Icon
    ____________________________

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
    ____________________________
  • ciphercipher Posts: 2 [Apprentice Seeker]
    I had tried the Revo Uninstaller option, as it was mentioned in an earlier post, but didn't make any difference. Anyhow, I tried both of the ways you suggested, but the problem persists as described in my post.
Sign In or Register to comment.

Who's Online23

s-i-g-g-i
s-i-g-g-i
+22 Guests