GO 520 WIFI does not any more alert the speed cameras. — TomTom Community

GO 520 WIFI does not any more alert the speed cameras.

ErkkiOH2EHErkkiOH2EH Posts: 10 [Master Explorer]
edited April 2019 in TomTom Services
My unit worked ok for some months, but then it asked to load a map. After loading a map the navigation works ok, but the lifetime speed camera and TomTom Traffic do not alert any more.
S/N: ZNxxxIxxx99 8PN5.002.02.5

Mod edit: Please don't post private or personal information on a public forum.Thanks

Answers

  • DougLapDougLap Posts: 7,727
    Superuser
    Hi @ErkkiOH2EH

    If you Tap Menu is the Cloud Icon Bold or greyed. If not Bold then Tap Settings, Tap My Drive and if it is Not saying Stop Syncing bottom right then you need to input Password and log your unit into your Account.

    Doug
  • ErkkiOH2EHErkkiOH2EH Posts: 10 [Master Explorer]
    My Drive is saying Stop Syncing bottom right, but when I connect the unit into PC, it disconnects the internet of the PC.
  • ErkkiOH2EHErkkiOH2EH Posts: 10 [Master Explorer]
    I am now waiting that the Stop Syncing sign disappears.
  • DougLapDougLap Posts: 7,727
    Superuser
    Hi @ErkkiOH2EH

    No. If it is saying Stop Syncing then it means that the unit is connected to your account and that is what you want.

    If you Tap Settings then Tap System then Tap About does it say Traffic and Speed Cameras Activated.

    I have flagged you to @VikramK to see if he can check your account settings in case there is something that can be sorted at their end. If he finds something he will let you know here so keep an eye here.

    Doug
  • VikramKVikramK Posts: 11,624 Moderator
    @ErkkiOH2EH

    The services are active and all good on your account.

    https://uk.support.tomtom.com/app/answers/detail/a_id/10316

    Try the steps on the above FAQ to troubleshoot any issue related to TomTom Services.

    Regards
    Vikram :)
  • ErkkiOH2EHErkkiOH2EH Posts: 10 [Master Explorer]
    I have resetted the unit several times, but it still does not alert the speed cameras, and TomTom Trafic is not working either.
  • ErkkiOH2EHErkkiOH2EH Posts: 10 [Master Explorer]
    I have resetted the unit several times, but it still does not alert the speed cameras, and TomTom Trafic is not working either.
  • YamFazManYamFazMan Posts: 19,248
    Superusers
    Hi
    @ErkkiOH2EH

    From the main screen... Tap (.... Menu) ->
    Are any of the Sound Icons... Slashed Through

    ut3giyunxxhg.jpg

    (1).... From the main screen... Tap (.... Menu) -> Setting -> Voices... Choose a Computer Voice
    Set the next 5 Setting to... 'ON'

    (3)... For general improvement using the Tomtom Speed Cam Database over the default settings

    Always use a Computer voice...
    Also....
    From the main screen... Tap (.... Menu) -> Setting -> Sounds & Warnings...
    Set... 'Warning Type' to... Read Allowed... (Important... Needs a Computer Voice set in the Voices menu)
    Speed Cameras & Hazards... Set to ON
    The next 10 Setting ALL set to Always
    The next 4 Settings ALL set to ON
    The device will now say....
    'Fixed Camera'
    'Mobile Hot Spot'
    'Red-light Camera'
    'Accident Black-spots
    ‘Spoken Traffic delays’


    Speed Cams
    If you keep a check on the Traffic-bar... The device gives you a visual Warning of the next Fixed or Mobile Speed Camera many miles before you reach the camera
    Even more info if in the 'Setting menus' you setup a Wide Traffic/Route Bar
    93197384-69ec-4f9d-b7ae-f68a6f82ffae.jpg

    ATB YFM
  • ErkkiOH2EHErkkiOH2EH Posts: 10 [Master Explorer]
    Thank you, I'll come back after testing...
  • waywardlife4mewaywardlife4me Posts: 2 [Apprentice Traveler]
    I have recently experienced the same problem with my Go 520 Wi Fi Navigation device. After repeatedly trying to correct the problem from a very unhelpful TomTom site that gives you the run around. I found the easiest way to resolve the situation has been to dump the TomTom device and use the Google Maps on my smart phone which alerts me to mobile speed cameras ahead when actually there and not just a possible site.
    Anyone wanting a to purchase a cheap Go 520 Wi Fi without speed camera functions feel free to make contact.
  • YamFazManYamFazMan Posts: 19,248
    Superusers
    Hi
    @waywardlife4me

    Tap 4Dot (.... Menu) -->
    iqu82qfc882o.jpg

    For a general improvement using the Tomtom Speed Cam Database over the default settings

    Always use a Computer voice...
    Serena or Malcolm here in the UK
    Karen in Australia
    Also....
    From the main screen... Tap (.... Menu) -> Setting -> Sounds & Warnings...
    Set... 'Warning Type' to... Read Allowed... (Important... Needs a Computer Voice set in the Voices menu)
    Speed Cameras & Hazards... Set to ON
    The next 10 Setting ALL set to Always
    The next 4 Settings ALL set to ON
    Now after the normal Warning double 'Ding'
    The device will now 'Say' the name of the Warning ....
    'Fixed Camera'
    'Mobile Hot Spot'
    'Red-light Camera'
    'Accident Black-spots
    ‘Spoken Traffic delays’


    Speed Cams
    If you keep a check on the Traffic-bar... The device gives you a visual Warning of the next Fixed or Mobile Speed Camera many miles before you reach the camera
    Even more info if in the 'Setting menus' you setup a Wide Traffic/Route Bar
    93197384-69ec-4f9d-b7ae-f68a6f82ffae.jpg
    ATB YFM
Sign In or Register to comment.

Who's Online in this Category0