My brand new TomTom GO Premium X says Traffic and Speed Camera updates are "Expired"

prvincent
prvincent Registered Users Posts: 9
Master Explorer
edited December 2021 in Devices using Wi-Fi®
I have just bought a TomTom GO Premium X to replace my old GO 6000 (you can see both devices listed for my account [email protected]). However, from the menu, if I select System->About, it says that both Traffic and Speed Camera Updates are "Expired". But the TomTom GO Premium X is supposed to have Lifetime Traffic and Lifetime Speed Camera Updates. So what's going on, please? Surely it shouldn't be saying these services are expired, since they should both be active for the "Lifetime" of the device?

Mod edit: Please don't post private or personal information on a public forum. Thanks :)

Best Answer

Answers

  • DougLap
    DougLap Posts: 9,959
    Superuser
    edited April 2019
    HI @prvincent

    If you don't hear from @VikramK on here today contact Customer support and ask them to sort your account out. So keep looking here.

    Customer support numbers here.

    https://discussions.tomtom.com/en/discussion/988105/customer-support-phone-numbers/p1

    Doug
  • prvincent
    prvincent Registered Users Posts: 9
    Master Explorer
    Hi Vikram,

    Thanks for the speedy reply (still no reply via the customer service question, which is why I duplicated my question here - apologies if it caused any confusion). Sadly, the System->About screen still says "Traffic - Expired" and "Speed Camera Updates - Expired". (No mention either way of Lifetime Map Updates, so hopefully they're OK). Likewise, when I tap the row of icons in top-right of the main menu, it says "Traffic - Expires soon". Do I need to do anything else to pick up the activated services? Factory Reset, for instance? I'm connected to my home Wi-Fi, by the way.

    Regards,
    Paul
  • prvincent
    prvincent Registered Users Posts: 9
    Master Explorer
    Hi Vikram,

    Just noticed an email arrived in the last few minutes, regarding my support question, advising me to do a factory reset, so please ignore the above. I'll do that now, and hopefully all will be well. Thanks again!

    Regards,
    Paul
  • prvincent
    prvincent Registered Users Posts: 9
    Master Explorer
    All sorted now - the factory reset picked up all the Lifetime Subscriptions, and all is well. Thanks once more to Vikram, and to Richa from Customer Support.

    Regards,
    Paul
  • prvincent
    prvincent Registered Users Posts: 9
    Master Explorer
    (Thank you to DougLap, too - the pointer to the support phone numbers was helpful.)
  • Stevemo1
    Stevemo1 Registered Users Posts: 4
    Apprentice Seeker
    Have the same problem but only with speed cameras saying expired in 2012! Tried several attempts at factory resets but remains the same bit annoying for a brand new device any help would be appreciated considering returning
  • prvincent
    prvincent Registered Users Posts: 9
    Master Explorer
    Stevemo1 - Contact Customer Support, and they'll sort it out. It was doing a factory reset AFTER they'd activated my services for me that solved the problem, not just the factory reset (see DougLap's link, above). Good luck!
  • GrahamBrent
    GrahamBrent Registered Users Posts: 1
    New Seeker
    I have the same issue - customer support is now closed - anyone still online who can help?
  • DougLap
    DougLap Posts: 9,959
    Superuser
    Hi @GrahamBrent

    Sorry to say there will not be any Mods on here until Monday morning.

    Doug