Rider 420 not connecting to iPhone after upgrade

TTR420User Registered Users Posts: 13
Apprentice Traveler
I had not used my TomTom Rider 420 since January until two weekends ago, and everything was fine. Knowing there must have been upgrades since then I connected it to MyDrive Connect and there was a software update, so I let that run. When I came back to the computer later the TomTom said the update was unsuccessful, but MyDrive Connect showed it as having been completed, and the device seemed to work.

Except when I actually went to use it, it could no longer share my network connection over bluetooth. It connects but then immediately loses the connection, and this just keeps repeating. I have tried removing, restarting, and repairing with no success.

Because of the claim that the upgrade was unsuccessful I did a factory rest and eventually a full reset of the TomTom (hold down power for the diagnostics screen, triple-click, plug into MyDrive Connect, and let it restore) but that made no difference. I even did that twice, the first time there was a Nav4 update in MyDrive Connect (I did not not the version number) to perform afterwards. It still did not fix the problem, so thinking that upgrade might have been the one that started all of this I tried another full reset hoping to get back to the original state. But the problem persisted and there was update was no new update offered then anyway.

Looking on the device it says the version is 17.300.0018.311 (0) (2017-10-12) . The OS version on the diagnostic screen is 3.2.0-ge08afb3

My phone is an iPhone 6 running iOS 10.3.3 and is completely unchanged from how it has always worked with the TomTom, so it should not be causing a problem. I have not performed any upgrades on it for a long time (there was a reason why I did not upgrade beyond 10.3, though I have long since forgotten what it was!)

The TomTom will, though, connect via my iPad Mini 4 (also running iOS 10.3.3). Which was interesting but not useful as I will not have that with me on the bike (and its data is more expensive!). My iPad can still share the internet connection of my phone too, so I know that internet connection sharing on the phone it still working.

And unrelated to the above, the quick settings menu icon as moved from the top left corner of the screen to just above the menu button in the bottom left corner in portrait mode, which is how I use it (it is more helpful to see more of the road ahead than to either side). How do I get it back where it belongs, as it is obviously much easier to access the two buttons this way when on the bike with gloves?

Can anyone offer any help with the above? It worked fine before the software update, just nothing since. But searching online it does not seem to be a known problem.



  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    You cant try to Reset the iPhone Network Settings. Settings — General — Reset — Reset Network Settings. iPhone will restart to do this Reset Network.

    If this still doesn't work also reset the rider back to factory defaults.
  • TTR420User
    TTR420User Registered Users Posts: 13
    Apprentice Traveler
    I did not know about that option on the iPhone, and it did not come up when searching for help, so thank you for that. But unfortunately it did not help.

    After reseting on the iPhone did not help the first time I tried reset everything:

    On the iPhone I removed the pair, turned off bluetooth, and reset network settings.

    On the TomTom I performed a reset (system menu) then a restore (triple click).

    So everything should be as clean as possible without completely wiping the phone. (Something I had to do recently, but really is a very last resort given the time it takes to re-download apps again.)

    Sadly it had exactly the same result. They pair, the TomTom connects, and the iPhone shows the black bluetooth icon. Then immediately after the TomTom loses the connection, the iPhone icon goes grey, and its blue bar network sharing bar never appeared.
  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    I am afraid you have to do the full factory reset your iPhone. (Do a Backup First)
  • TTR420User
    TTR420User Registered Users Posts: 13
    Apprentice Traveler
    I think that worked! I mean, it did but now there is something else sharing the internet connection too which is quite odd.

    As soon as I enabled the personal hotspot after wiping and restoring the iPhone (save for the apps which are now downloading) something immediately started sharing the connection over wifi (bluetooth was not yet enabled).

    I have no idea what it could be, I checked all my devices and it was none of them. And even stranger, changing the password did not disconnect whatever it was. Not even after turning the hotpot on and off with the new password. And as that is not even shared in the iCloud keychain, the only thing that could know the new password was the phone itself.

    But the TomTom paired and this time held the connection. Hopefully it will still do when nothing else is sharing the connection. Still confused why upgrading the TomTom software caused a problem on my iPhone, and quite annoying what I had to do to get it working again, but it seems to be doing so for now.

    Thank you.
  • TTR420User
    TTR420User Registered Users Posts: 13
    Apprentice Traveler
    Well, that did not last long.

    Firstly, I was an idiot and worked out what was sharing my internet connection. The iPhone was still connected my MacBook for iTunes to restore everything, so it was sharing the connection via USB even though nothing was using it.

    Anyway, I had turned off my phone (as did not want to leave sharing on when not knowing what was doing so) but then went to pair with my headset, a Cardo Scala Rider Q3. The TomTom complained after pairing it was incompatible, so I did a reset on the Scala, and it paired and connected okay.

    So now I knew what was happening with the phone, disconnected it from USB, turned on sharing, and it was back to the old problem. Turned the TomTom off and on, and it had lost the pairing. Recreated it and still the same. I do not want to restart my iPhone whilst it is downloading, but reset the TomTom also did nothing to fix the problem.

    It connects, then immediately disconnects, the iPhone briefly shows a bluetooth connection but never shows the blue internet sharing bar.
  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    Strange, and I can't think of any other options.

    You cleared TomTom BT settings and cache with the drum reset.
    And dit the same with the iPhone with the factory restore.
    Even dit the same with the Cardo.

    Everything should be clean and working.

    You can try to contact TomTom Support.
  • Ste7ios
    Ste7ios Posts: 759
    Continuing connections - disconnections also had with the Rider 400 and iPhone 6 (latest iOS always) but it stopped by its own will...

    I’m sure that there’s some crazy AI in the Rider...

    Things also go mad if I pair both of my Cardo headsets. It has to forget the second if I remember correctly.

    I’m afraid that the Bluetooth stack of TomTom is a mess...
  • TTR420User
    TTR420User Registered Users Posts: 13
    Apprentice Traveler
    I said I had done a complete reinstall of my iPhone before, that was because over the years the "Other" had built up and so had lost a lot of storage space. I am not sure what happened yesterday, but after doing it again I both had a few GB of "Other" even after the missing apps had downloaded, and most of my music and podcasts would not sync. So the TomTom seems to have broken that now too.

    As it meant having to redo the reinstall of my phone I had one more, unsuccessful attempt, of trying to get this working. I am noting it here just so I can point TomTom Support to this thread.

    First I reset the Cardo Scala Rider Q3 to remove all pairings, and turned it off.

    Then I removed all pairings from the TomTom Rider 420, did a reset (system menu), and when it rebooted I did a restore (triple click).

    Next I removed the pairings to the Scala and TomTom on my iPhone and powered if off-and-on (as this is what Apple recommend to reset bluetooth problems).

    I connected my MacBook to an ethernet connection (as my media is on a network drive), then performed a backup of my settings.

    After unplugging the iPhone I erased all contents and settings, then plugged it back into iTunes, and let it restore. Still a lot of "Other" but hopefully just the data for the apps still downloading. All the music seems to have synced this time, but only a few podcasts. In the end (after the below) it took two cycles of removing and re-adding podcasts in iTunes to get them back, adding another 1.5GB to the "Other" in the process. Regardless of the TomTom, I think I may need to reinstall the iPhone again in the near future.

    Anyway, as per a tweet from @TomTom I went to a help page on pairing, which suggested using the MyDrive Connect app. It was of no help. Putting aside the TomTom layout does not match the instructions, despite the page saying it applied to my model, it said to pair the device via the iPhone's settings. But it never appeared in the devices list on it. So instead I had not choice but to select the iPhone from the TomTom instead.

    And when I did it had the exact same problem it had had all along, It would say it had connected to the phone, the iPhone bluetooth icon would go black, no blue sharing bar would appear, the TomTom would say the connection was lost, and the iPhone icon go grey.

    So now to send a link to this thread to TomTom support because I cannot think what else I can possibly do. I got everything to the cleanest possible state I could before trying this one last time. But I am not optimistic, so will just have to hope there are no roadworks or accidents this weekend without any internet access.

    Thanks for the help.
  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    Reading this I think the factory reset of your iPhone din't clear all settings.

    You can try a recovery mode factory reset of your iPhone 6 .
    Its best to also repeat the Riders drum reset and Cardo reset so you have a fresh start.

    First try to get all working without Cardo and add this one later.
  • TTR420User
    TTR420User Registered Users Posts: 13
    Apprentice Traveler
    I am back, and bear no good news.

    As I was away over Easter I was unable to do anything more about my problem, though I had my iPad for the trip so was able to make use of that for the TomTom. After a busy week I have just tried reseting everything again but to the same results as before.

    Not helped that I have forgotten how to do a factory restore of my iPhone, which i am sure is what I did before. The problem is if I put the iPhone in DFU mode then iTunes offers the option of upgrading or restoring. If I select restore it then tells me checking for updates is disabled and gives me the option of checking or cancelling. Cancelling means cancel the restore, apparently.

    But checking means I get a dialogue box that tells me to update to the latest iOS I need to update iTunes, for which I need to update OS X. And so it then does nothing. Unsurprisingly, option-cliking on Restore and selecting the original firmware file for iOS 10.3.3 does not work because Apple's servers will no longer sign it.

    (Incidentally, I was using an app this past week that has not been updated, and loading the first time after resetting brought up a warning it will no longer work in iOS 11, so I think that is part of the reason I did not upgrade iOS. Though the need to upgrade macOS, which would also cause incompatibilities, to upgrade iOS is also a reason why simply upgrading my iPhone is not an easy solution.)

    And this is now a much big problem because I have a private server I use for notes and contacts etc. so uses a self-signed certificate. This was never a problem, because I would manually trusted that certificate and everything worked.. But since resetting and restoring I now get constant dialogue messages on the iPhone telling me the certificate identity cannot be verified. When I click on details the Trust button is no longer available, presumably because it is already trusted, so I cannot stop this happening. And resetting network settings does not fix this either, which is very annoying.

    Finally, despite contacting TomTom Support last week, and getting a subsequent reply on Twitter (in which response to a separate complaint) saying they would reply to it, they have not.

    So right now things are a complete mess, and I have very little regard for TomTom, both the products and customer service.
  • TTR420User
    TTR420User Registered Users Posts: 13
    Apprentice Traveler
    A little more investigating. I decided to see what would happen if I wiped my iPhone and tried to pair it with the TomTom in its as-new state. It worked!

    So clearly the problem is something stored within the backed up settings. Unfortunately I need my messages and voicemails etc. so I need to to restore it from a current backup to be usable, but at least this has helped locate the problem.

    I did try restoring my backup after the successful pairing, but the restore just made a complete mess of my iPhone so I had to reset it and restore it back to the "broken" state to at least have a usable phone again.

    As I have an encrypted iTunes backup, my next idea is to try making an unencrypted one to see if that loses all the bluetooth (and certificate) data. It depends on whether Apple consider such things to be sensitive.

    Unfortunately I do not have time to do anything more tonight and will not be home tomorrow, when I will be needlessly taking my iPad on the bike, so it will have to wait until next week.
  • TTR420User
    TTR420User Registered Users Posts: 13
    Apprentice Traveler
    I have finally received a reply from TomTom Support. It told me to reset the TomTom through the menu and then unpair and re-pair the connection.

    Given I sent them a link to this thread which details how I have dozen this over a dozen times I cannot hold them in any less contempt.

    But, that should not overshadow the happy ending.

    My assumption about using an unencrypted backup was correct. After the latest erase and restore of the iPhone the bluetooth menu was empty. So whatever was corrupted within the backup was lost, and when I tried to pair the TomTom it connected first time.

    I will have to pair other devices as and when I need them, but that is not a major problem.

    Unfortunately Notes and Mail were still not working, with the same certificate error. So I tried turning them off and on, but this just lost the old data that has been backed up. So then I tried changing the password on the iPhone (to an incorrect one, as if you change it to itself it knows not to check it). I have no idea why, but when it connected to the server it brought up the proper dialogue with the option to trust the certificate. After the password failed, I set it back to the real one and that all works too.

    An altogether annoying experience, but thankfully now resolved. Sadly despite TomTom Support, but many thanks RoadRider as you definitely helped lead things towards the solution.

    That all said, there is still the one issue from my original post that following the upgrade, the quick settings menu icon location when in portrait mode.

    Is that a change in the upgrade? I know it seems a trivial issue, but it is somewhat important as there are times when riding I need to access those options. And with gloves it is difficult to make sure you hit the correct icon with it and the full menu icon in the same corner.

    For quick settings, if I am following a track and need to deviate from it (personal knowledge, road closed, etc.) I want to mute the TomTom to stop it telling me to turn after every side street as it tries to get me back to the original track.

    And other times I just want to abandon a track completely to let the TomTom pick the quickest route home, so I position that option at the top of the menu so I can do it in two presses.
  • TTR420User
    TTR420User Registered Users Posts: 13
    Apprentice Traveler
    So, that was premature.

    The very first time I tried to use the TomTom since re-setting it up and testing it and it has the exact same problem as before. It just would not share iPhone's internet connection and would kept making and dropping the bluetooth connection.

    After the TomTom software upgrade I was able to connect to my phone, but on making that connection it obviously did something to it as it then would not connect again.

    Clearly whatever it did then has happened again.

    With a clean phone it made that initial connection when I tested it last week, but it must have done the same thing to it so that it again can no longer make a connection.

    I have not done a full reset (triple click and erase the iPhone) but I have just done the basic's as recommended by TomTom and Apple (system menu reset the TomTom, and remove the pairing and restart the iPhone) and it did not help.

    For whatever reason it seems that software upgrade has made the TomTom incompatible with my iPhone.