GO 600 TomTom -Unit not charging — TomTom Community

GO 600 TomTom -Unit not charging

Hi, my Go 600 has suddenly stopped charging. I thought it was the official Tomtom car charger and USB cable, so replaced those with another official set. Still no joy, so tried connecting it to my PC on a USB cable that always works to do the updates on MyDrive Connect. I turn the unit on, and the red battery warning shows and the unit closes down.

The unit is 4FA60 4FA6.001.06.

Any advice appreciated.

Thanks, John

Best Answer

  • DougLapDougLap Posts: 2,941 Superuser
    Accepted Answer
    Hi @JohnOrrett

    Sounds like a battery failure.

    You can get replacement batteries form Fleabay and if you search youtube for Replace battery on Go 6000 you can see videos on how to do it..

    Doug

Answers

  • DougLapDougLap Posts: 2,941 Superuser
    Accepted Answer
    Hi @JohnOrrett

    Sounds like a battery failure.

    You can get replacement batteries form Fleabay and if you search youtube for Replace battery on Go 6000 you can see videos on how to do it..

    Doug
  • JohnOrrettJohnOrrett Posts: 8 [Master Explorer]
    I have a brand new One battery and wondering whether it will be suitable.

    600 unit is 3.7v 1100mAh. One is 3.7v 1300mAh

    600 is 4.07Wh. One is 4.8 Wh.

    Both have a 3 wire connector block. Not sure if the differences would kill my 600.

    Any advice appreciated :)
  • down_underdown_under Posts: 2 [Apprentice Traveler]
    JohnOrrett wrote: »
    Hi, my Go 600 has suddenly stopped charging. I thought it was the official Tomtom car charger and USB cable, so replaced those with another official set. Still no joy, so tried connecting it to my PC on a USB cable that always works to do the updates on MyDrive Connect. I turn the unit on, and the red battery warning shows and the unit closes down.

    The unit is 4FA60 4FA6.001.06.

    Any advice appreciated.

    Thanks, John

    Same thing happened to my GO 600. I bought a replacement battery package from Walmart. It comes with a tool and instructions. Its as good as new after then.

  • JohnOrrettJohnOrrett Posts: 8 [Master Explorer]
    Thanks for the advice down_under. Unfortunately it looks like the circuit board has short circuited, as there is a burn mark on the board :/
Sign In or Register to comment.

Who's Online17

jayrko
jayrko
Jim07
Jim07
Jürgen
Jürgen
karstenk
karstenk
levitt
levitt
Philbeav
Philbeav
+11 Guests