Live Traffic not working

Tight Git
Tight Git Registered Users Posts: 5
Master Explorer
Hello,

The traffic sidebar has suddenly disappeared from my Live 825 device, even though my subscription is valid to Dec 2019.

Please keep it simple as I'm very old and not good with technology!

Thank you.

Comments

  • Tight Git
    Tight Git Registered Users Posts: 5
    Master Explorer
    Is there nobody out there who can advise an old chap, please?

    I drove my wife to Tunbridge Wells today and got stuck in a traffic jam that I might have avoided.

    Thank you.
  • dhn
    dhn Posts: 33,388
     Superuser
    A call to support maybe:

    United Kingdom
    02079 490 132
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    Don't provide a model when prompted in order for a live agent to come on line. Appears your model might be End of Life. That said, valid subscriptions are supposed to be honoured. So call.
  • Tight Git
    Tight Git Registered Users Posts: 5
    Master Explorer
    Hello again, back with an update.

    Contacted support (thanks dhn) and spoke to a nice young lady called Padma.

    It appears that, for some reason, I'd lost the "Me & My Device" option under Settings and so was not sharing my information which is necessary to use Live Traffic.

    My problem was referred to a senior technician who issued a special update and all is now working OK again.

    I hope this information is of use to someone with a similar problem.
  • Pempacat
    Pempacat Registered Users Posts: 8
    Neophyte Traveler
    Thank you - I have sorted the information already and still no joy. I will however use the phone number!!