Device won’t start — TomTom Community

Device won’t start

Hi I have a Start 20 and when I turn it on I briefly get a cog turning then a Red Cross. The tomtom site says I should be able to hold the on/off button and get a text diagnostic screen but this doesn’t happen, it just goes to the Red Cross. Any help is appreciated.
Tagged:

Answers

  • LAURE123LAURE123 Posts: 1,632
    Superuser
    Hi @Fraze

    May be... If you see spinning cogwheel, it's because your device is already in Recovery Mode.
    9rk9bo19vwgz.gif

    And you don't need to do the 3-press process.
    You are at N°8 of this FAQ:
    https://uk.support.tomtom.com/app/answers/detail/a_id/1898/related/1

    Try this:
    - charge your device with a main charger (smartphone/Iphone/Tablet 1 or 2A) at least 2/3 hours, the Recovery Mode require a full battery.
    - Open MyDrive Connect software on your PC and log in with your email and password.
    - 'Switch Off' your device. Connect the cable directly to your computer USB port (no hub) and and to your device, the device 'switch On'.
    The device must be connected to the PC and MDC when the spinning cogwheel is on the screen.
    - The PC download and reinstall the NavCore, the internal software. Your device will restart during the process, wait and leave it connected to the PC until it has a normal display.

    I hope it will work for you, If not contact TomTom Customer Service for more help:

    See here @Niall topic:
    https://discussions.tomtom.com/en/discussion/988105/customer-support-phone-numbers/p1

    Regards.
Sign In or Register to comment.

Who's Online in this Category0