Live traffic not working

Snowtiger10
Snowtiger10 Registered Users Posts: 2
Apprentice Traveler
Just renewed my live service subscription and now live traffic has stoped working. All other live services still work ( places and speed cameras etc). Tried a factory reset and still no joy. Just get a yellow triangle with ! In the info bar.

Any help appreciated
Tagged:

Comments

  • TonyB70
    TonyB70 Registered Users Posts: 1
    New Traveler
    My live traffic has stopped working. All other live services still work (places and speed cameras etc). System seems to reboot often. Tried a factory reset and still no joy, I Just get a yellow triangle with ! In the info bar. How annoying this is, has been like it for over a week now.....any help would be very much appreciated....aaaahhhhh
  • PeterBennet
    PeterBennet Registered Users Posts: 4
    Master Traveler
    Live traffic has stopped working for me too.
  • DougLap
    DougLap Posts: 10,052
    Superuser
    Hi @PeterBennet

    What Tomtom unit have you got?????

    Doug
  • PeterBennet
    PeterBennet Registered Users Posts: 4
    Master Traveler
    Hi, thanks - Start 25
  • DougLap
    DougLap Posts: 10,052
    Superuser
    Hi @PeterBennet

    Contact Customer Support. Contact number detailed below.

    https://discussions.tomtom.com/en/discussion/988105/customer-support-phone-numbers/p1

    Doug

  • PeterBennet
    PeterBennet Registered Users Posts: 4
    Master Traveler
    Thanks, I have already emailed them so we will see what they have to say.
  • DougLap
    DougLap Posts: 10,052
    Superuser
    Hi @PeterBennet

    You may find that you get a quicker response if you contact them via phone as they can check the settings at their end for your unit and account while you are on the phone. Changes made then are effective straight away.

    Doug
  • Pela
    Pela Registered Users Posts: 3
    Apprentice Traveler
    It does not work either. I am near Berlin! How to go? Like a blind man. and the money paid for Live Traffic!
  • DougLap
    DougLap Posts: 10,052
    Superuser
    HI @Pela

    You will need to contact Customer support, number below. Not open now until Monday now..

    What TT unit do you have

    https://discussions.tomtom.com/en/discussion/988105/customer-support-phone-numbers/p1

    You could try a Soft Reset. With the unit on Hold the ON/OFF button down until you hear a Drumroll sound then release the button. It will boot up again. See if live services then work.

    Doug