TT Sports App not working with Android 9 — TomTom Community

TT Sports App not working with Android 9

My phone recently updated its software to Android 9. Since then the app won't work - it repeatedly crashed when opened. I reinstalled the app but it didn't fix it. Has anyone else encountered the same problem? It was working fine before this.

Comments

  • tfarabaughtfarabaugh Posts: 16,723
    Superusers
    It may be the app has not been updated for Android 9 year but you can reset the connection following these steps. You first need to remove the watch from the phone's BT menu (in iOS you have it forget the device) after you reset or try pairing again and remove the TomTom_MySports folder from the internal storage of the watch (plug it into a computer and you will see it as a hard drive and can delete it there). The steps are: uninstall the app, remove or forget the watch from the phone's BT menu, factory reset the watch, reinstall the app, select Pair New on the app, select Pair New on watch (press down from the clock and select Phone>Pair New, not Sync) and follow the prompts on the phone. You should not be pairing the watch first through the phone's BT menu; it is all done through the app and you must have the phone forget the watch in the BT menu before re-pairing.
  • patpalloonpatpalloon Posts: 106 [Prominent Wayfarer]
    I did all the steps above except factory reset of the watch. The app worked the first time when setting up and updated quick GPS etc but every time since it crashes.
  • patpalloonpatpalloon Posts: 106 [Prominent Wayfarer]
    However, lately the app seems to be stable and isn't crashing. If I open the app first, switch on Bluetooth and then connect the watch it has worked a few times.

    I'm not sure why it is now working, nothing has changed. I will continue to monitor.
Sign In or Register to comment.

Who's Online in this Category0