Watch screen is blank

HelenKrag Registered Users Posts: 1
New Traveler
edited January 24 in TomTom Sports
My watch screen is blank and I tried a reset with the Connect App, but this is stuck on 'RESETTING Good as new in a moment'. The 'moment has been over an hour. Any tips?


  • tfarabaugh
    tfarabaugh Posts: 16,975
    I would try to perform a reset on your watch using the recovery mode, follow these steps:

    1. Place your watch in the dock before you connect the dock to the computer.
    2. On your watch, move DOWN but keep the button pressed. If the USB port on your computer is not easily accessible, connect the dock to the computer without the watch. Then move down from the clock screen while you slide the watch into the dock.
    3. Connect the dock to the computer. Keep pressing the button until your watch shows
    4. Release the button and wait for Sports Connect to show Update.
    5. Click Update in Sports Connect.

    If that does not work, you should contact Customer Support. They can more deeply investigate and diagnose problems than we can here on the user forum. To get in touch with Customer Support, choose Contact Us at the bottom of this page, select the service required and the product name and click Contact Customer Care and then Email Us or Chat (there is no longer phone support available for watches).
  • Biran
    Biran Registered Users Posts: 1
    New Traveler
    My golf watch screen goes blank on the course. I don’t appear yo be able to reset it by holding the button down. What am I doing wrong
  • frouste
    frouste Registered Users Posts: 1
    New Seeker
    Same issues here. I've followed the 'Factory Reset in Recovery Mode' process a few times.
    Sports Connect on my computer reaches "RESETTING: Good as new in a moment" but hangs there for over an hour. The watch screen goes blank, and flashes the TomTom logo every now and again.
    I've tried again waiting for "Update" instead of "Reset" in the Sports Connect app (as mentioned above), but it didn't appear.
    I've tried cleaning the points on the watch with an eraser (mentioned in another discussion) to no avail.
    It's clearly connected just not able to complete the reset. Is there an alternative? Power it down? Open it up?