Cannot update/install map on my GO 40

SaraG Registered Users Posts: 2
New Seeker
I bought a new map (UK) for my Go 40.
I downloaded and fired up MyDrive Connect and plugged in the unit.
The first thing it seems to have done is update the software leaving the device without any maps.
I downloaded and started the install of the map and it appears to have trashed my unit while it continuously disconnects during the update/installation and I get loads of "not connected to internet" messages from MyDrive Connect even though the laptop has a perfectly stable 100GB ethernet connection.
Anyone got/had similar experiences as I've wasted hours on this?


  • dhn
    dhn Posts: 33,388
    Seek help from support:

    United Kingdom
    02079 490 132
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • SaraG
    SaraG Registered Users Posts: 2
    New Seeker
    I already tried that but, selecting the correct menu offerings when I called, I was advised that as the unit is an older model they do not provide any phone support whatsoever but simply directed me to their web support pages which contain absolutely noting of help.

    In the meantime I've managed to get the download completed by using another PC. It took one hell of a long time but eventually worked.
    The issue was that the download/installation had aborted mid session first time round and left what appeared to the unit to be a corrupted map.

    Problem solved but I've no idea why it occurred in the first place as my Surface is much newer, faster and more reliable than my old desktop.