Stuck on checking 100%

FMaz Registered Users Posts: 6
Apprentice Traveler
edited August 2019 in MyDrive Connect
Using my drive connect
GPS model: 4EN52
model detected by My drive connect: Start 25.

I have already uninstalled the software and removed all updates. I have reinstalled the software.

Out of the 4 updates, I have unselected the map one. The 3 updates selected are small in size and should be fast.

The default option to download on the computer is enabled.

Now I'm stuck again in "Checking 100%".

After waiting for hours, I tried to cancel, but I can't cancel and start over.
(Even if I disconnect the device, or shut down the software, as soon as I reconnect or reopen, it goes right back to "Checking 100%".)

Searching the forum and google shows this has been an issue for years now. Could this software be made open source?


  • dhn
    dhn Posts: 33,382
    Seek advice from support:

    :flag_ca: Canada (en)
    1 877-757-7137
    Monday - Friday: 9:00 a.m. to 7:00 p.m. EST
  • FMaz
    FMaz Registered Users Posts: 6
    Apprentice Traveler
    Got to love how all the search for this issue brings hundred of results, all saying to contact support and deprived of any useful info.

    You guys really nailed what a support forum is meant for.
  • dhn
    dhn Posts: 33,382
    This is a USER forum, not Support. I'm a user just like yourself. Maybe somebody else will pop into this thread with a better suggestion. If you don't want to try the Support line then that's up to you.
  • FMaz
    FMaz Registered Users Posts: 6
    Apprentice Traveler
    So as a user, here are some actually useful instructions for the next person who would find this topic:

    1. shut down My Drive Connect. X out, then check your tray icon, right click and Quit.
    2. Unplug your tomtom device.
    3. If using Windows, Press Win+R to bring up the Run prompt. Type %localappdata% (include the %). Hit Ok
    4. Go in the folder TomTom/.
    5. Delete the folder HOME3/. This will reset My Drive Connect user preferences and cache.
    6. with your GPS being off, press and hold the power button for 40 seconds, or until you hear the drum roll. This should open, then reset the device.
    7. Now reopen My Drive Connect, leave the default option as is.
    8. Login
    9. Reconnect your TomTom, prefer a USB3 (blue) port as they provide more power.
    10. Start with only the mandatory updates (unselect the map and the user shared content)
    11. Then update the map by itself.

    Stuck on 0% ?
    Now, My Drive Connect was most likely made by an intern paid with 6 pack of beers, so don't expect it to monitor your download in a reliable of informative manner. It will show "less than a minute left" instead of "calculating estimate" when at 0%. If you have a slower connexion, it will say "Less than a minute left" for a long time. If you want to confirm it is really downloading, check the task manager (Win+R, taskmgr or CTRL+Shift+Esc), find TomTom My drive connect and check the Network column to confirm it is actually downloading.
    Once the downlaod moves away from 0% you should get an estimate.
  • FMaz
    FMaz Registered Users Posts: 6
    Apprentice Traveler
    Ok, disregard my last paragraph.
    Although the application does use tons of network usage, a quick check of its disk usage revealed it's not writing anything at all. It's just using the network, not sure what for.

    The following is not a solution but just the result of exploration, should someone else try to take over from here.

    The good news is that the cache items are consistently being created in %localappdata%/TomTom/HOME3/cache/

    So opening the cache-status.xml file in a text editor reveal the remote location of the file being downloaded.

    If you download multiple files at once, you'll have to pay attention to the index (here we only have one file so the index is 1)

    The line I was looking for looked like this (note: I vetted the full path):
    The part you want to copy is the href="". So in this example, you'd copy

    Next I downloaded wget for windows (, extracted wget.exe in the windows folder.

    Once I had wget in place, I opened a command prompt and started to download the new map into the tomtom/ folder:
    cd %localappdata%
    cd tomtom/

    So now the file is being downloaded into the TomTom/ folder. Yay, finally something that works.

    Now I have tried to swap the file, edit the cacheLenght field, but everytime I restart the app, that get reset. I think the QtWebEngine must have some sort of primary cache with resume instructions hidden somewhere but I couldn't find it quickly.

    So I looked into by passing the app and alternative ways of uploading the new file on the device. I was able to figure out that the TomTom presents itself as a Network Adapter to the computer, and is always assigned IP . There is an HTTP server on the device:

    I still haven't figured a way to access the files or have a transfer working (and that's including with the app I'm supposed to use... it's sad.)

  • LAURE123
    LAURE123 Posts: 1,632
    Hi @FMaz

    TomTom uses a proprietary closed and secure system to update our devices. MyDrive Connect is the only way to perform updates, stop your manipulations it will not work...
    BL ==> Start 25, 4GB micro-SDHC, MyDrive Connect NAV3

    Your problem may be the lack of usable space on your Start25 which has only 4GB of internal memory (3,73GB usable).
    I don't know the size of the Canada map, I have the EU full map that is 4389MB and I don't know if you have access to smaller map zones like me.

    Install a micro SD card class 10 of 8 or 16GB (max 32GB) or look if you have the option to install a smaller map zone.

    For a smaller map zone, if it exists, like this:
    - Open the submenu of the map, in "My content" go down in "My Maps", click on the map picture, not on the button and choose "Install Smaller Map".

    For the micro SD card, TomTom uses a proprietary formatting mode performed by your device.
    - Put the micro SD card in the TomTom device, previously formatted in FAT32 with your PC.
    - Reset your device: Press and hold the Power button for about 30 seconds until you hear a drum sound, then release the button.
    The formatting starts automatically after the Reset, on the screen choose the option "Yes".

    For more help contact TomTom Customer Support as advised by @dhn :
    :flag_ca: Canada (en)
    1 877-757-7137
    Monday - Friday: 9:00 a.m. to 7:00 p.m. EST

  • FMaz
    FMaz Registered Users Posts: 6
    Apprentice Traveler
    Hi Laure,

    The map I'm trying to update (I already have an older version installed) is 1.8gb.

    The problem is that my internet connexion is a satellite connexion as I live in a remote area. And My Drive Connect is horrible piece of software to download.

    Where as wget downloaded the map on first try in about 10-15 minutes, My Drive connect take over an hour per attempt and always end up with a partial download or a corrupted map.

    Side note: I also have to monitor the folder size on my computer to monitor the download progress as the download will stay at "getting started" or 0% for the whole time.

    I have let My Drive Connect make multiple attempts so far, each ending up in a generic error that it failed to update.

    The numbers don't make much sense, but I have let try to download the map a total of 5 times. The cache file shows it had tried to download the map over 10 times and has somehow used over 60gb of data doing so (at $6 per gb, I'm sure you understand my frustration with this garbage software)

    Hence why I'm trying to find a way to use my drive connect only to transfer the map, which I already have downloaded.

    Sd card might be a good. Not because I need more space but I can most likely access that.

    At the same time, at this point it would be cheaper just to buy something else...
  • FMaz
    FMaz Registered Users Posts: 6
    Apprentice Traveler
    Oh, and I did contact Support btw.
  • LAURE123
    LAURE123 Posts: 1,632

    Indeed it's expensive, I realize that I don't appreciate my unlimited internet connection at its fair value.

    Forget the idea of ​​being able to access the contents of the micro SD card, after the proprietary formatting of your TomTom device, the content will be unreadable and unusable. No copy/paste possible, the system is locked.
    Screenshot of my micro SD content with a map:
    If there is a corrupted map, it must be removed before to start the update. The repair works very rarely... for me it's a waste of time.
    Try to remove the map but don't empty the cache as in the video maybe it will avoid you a new download.
    Your connection must be stable and not blocked by your antivirus/firewall/VPN.

    See this FAQ and video:

    I cross my fingers for you.
  • TheEdge
    TheEdge Registered Users Posts: 1
    New Seeker
    I had the same problem with my TomTom GO 610 - with MyDrive Connect stuck for hours on 100% Checking and still no sign from the device that anything had been installed at all. Re-set my device by holding down the power button for 40 seconds until rebooted and uninstalled TomTom Home 2 and TomTom Home 3 on my PC.

    Now the updates have gone through with no problem at all. Thank you all!
  • Kenneth562019_
    Kenneth562019_ Registered Users Posts: 2
    Apprentice Traveler
    I just killed the app using the Windows task manager, and then restarted it. Then it just started the update process....
This discussion has been closed.