No longer able to sync Watch to phone app

SadiekaSadieka Posts: 1 [New Traveler]
Even though i can see my watch name under bluetooth options. I'm unable to sync my watch to phone. This has recently become an issue. I have connected watch cable to pc and no version updates available. Please advise.

Comments

  • tfarabaughtfarabaugh Posts: 15,175 [Superusers]
    You should try and reset the connection. You first need to remove the watch from the phone's BT menu (in iOS you have it forget the device) after you reset or try pairing again. The steps are: uninstall the app, remove or forget the watch from the phone's BT menu, factory reset the watch, reinstall the app, select Pair New on the app, select Pair New on watch (press down from the clock and select Phone>Pair New, not Sync) and follow the prompts on the phone. You should not be pairing the watch first through the phone's BT menu; it is all done through the app and you must have the phone forget the watch in the BT menu before re-pairing.

    To do a factory reset, make sure the Connect software is running and dock the device to your computer. The Connect window will open; press the gear at the top right and select factory reset from the next screen. Follow the steps provided and when prompted to register or sign in to MySports, select sign in and use your existing account credentials. It is fairly straightforward and should take less than 5 minutes.
  • xray79xray79 Posts: 160 [Renowned Wayfarer]
    are the bars in the memory empty? If not you might have a corrupted activity. I also have issues with tidying up and connecting ot the phone app. But in general if i follow these steps it works.
    1. open Bt on the phone
    2. open the app on the phone and wait for the looking for watch
    3. on your watch select on in the sync activities menu
    4. leave the app open and screen on untill you see synching in progress.
    5. after the sync/GPS update is complete close the app and disconnect watch (turn off sync in menu on watch)
    in general this works for me.
Sign In or Register to comment.

Who's Online27

27 Guests