GO 5000 connects fine, but only for less than a minute — TomTom Community

GO 5000 connects fine, but only for less than a minute

ClareRClareR Posts: 4 [Neophyte Traveler]
edited January 2019 in MyDrive Connect
I have just upgraded my laptop to a nice new Microsoft Laptop 2, and have installed MyDrive Connect. I followed all instructions, but for some reason my GO 5000 device will only stay connected for about 30 seconds. The screen on the GO 5000 says it is connected and the Device Manager shows that the 'USB RNDIS Adapter' is still present (indicating that Windows thinks it is connected), but the MyDrive Connect (version 4.2.3.3635) says it is not connected. I can unplug it and plug it back in again, but between 20 and 30 seconds later it will say it is disconnected again. No noises from Windows, no apparent change of connection state (other then within MyDrive Connect) and no reason as to why this keeps happening.

On my old laptop there is no problem. It connects and it stays connected (using the same version of MyDrive Connect). I have also gone through the troubleshooting tips here (https://uk.support.tomtom.com/app/answers/detail/a_id/16339) which is why the name of the GO 5000 in the Device Manager is different.

Has anybody else had this? Can anybody suggest anything which I could try to resolve this?

Thanks in advance for your help,

Clare

Comments

  • YamFazManYamFazMan Posts: 18,666
    Superusers
    Hi
    @ClareR

    The Computer Manufacturers appear to be setting "USB Selective Suspend" to ON as default
    Especially Laptops, maybe to improve the look of the battery life
    _______________________________

    Re "Download/installation interrupted".....
    Are your USB ports set for power saving "USB Selective Suspend"

    Win10 See… https://www.tenforums.com/tutorials/73187-turn-off-usb-selective-suspend-windows-10-a.html
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Win7 See... http://www.sevenforums.com/tutorials/147369-usb-selective-suspend-turn-off.html
    Click on link and scroll down to "Turn Off USB Selective Suspend"

    Also turn off any Screen savers any other Power savers or USB port monitoring software installed
    ________________________________

    Random Disconnects on Surface Pro 3 & 4
    Do you have or have access to a 'Surface Dock', if so plug your device into a USB port on that. Others have found that to work

    On the Win10 tablets, Microsoft has hidden the "USB Selective Suspend" menu
    You will need to edit the Registry for the USB Selective Suspend menu to show

    See... https://en.discussions.tomtom.com/mydrive-connect-apps-474/still-can-t-update-my-go6100-on-a-surface-device-1039578/index1.html#post1234855

    See... https://en.discussions.tomtom.com/rider-51/update-fail-tomtom-rider-410-on-a-microsoft-surface-pro-3-windows-10-1025704?postid=1177921

    See... https://en.discussions.tomtom.com/mydrive-connect-apps-474/go-500-random-disconnections-on-surface-3-pro-968783

    ATB YFM
  • ClareRClareR Posts: 4 [Neophyte Traveler]
    I discovered that the network adapter was going disabled and that was the immediate issue. Following the links you have posted I have enabled the 'USB selective suspend setting' within the advanced power settings (via the registry to make it visible) and so far it is staying put. I hope it stays that way since we're at the 'Updating Device' stage now with an hour left to run. Really don't want to brick the GO 5000 if my new machine decides to turn off the network port again mid-update!

    Microsoft can be a pain in the backside sometimes. Thank goodness for people like you who know what they are doing! Thank you so much!!!

    Clare
  • ClareRClareR Posts: 4 [Neophyte Traveler]
    Curiously, on my older laptop, the 'USB selective suspend setting' was set to Enabled for both battery and plugged in. I wonder why it never seemed to cause a problem on that machine?

    C
  • YamFazManYamFazMan Posts: 18,666
    Superusers
    Hi
    @ClareR
    ClareR wrote:
    I discovered that the network adapter was going disabled and that was the immediate issue. Following the links you have posted I have enabled the 'USB selective suspend setting' within the advanced power settings (via the registry to make it visible) and so far it is staying put....
    You may have to repeat the registry hack for any future Major Win10 updates
    The last Win 10 update reset the 'USB selective suspend setting' back to Win10 default

    ATB YFM
  • ClareRClareR Posts: 4 [Neophyte Traveler]
    Any thoughts as to why it wasn't a problem with my older laptop? USB suspend was set to Enabled on that, yet MyDrive Connect worked fine and didn't skip a beat with that.
  • tugmantugman Posts: 337 [Revered Navigator]
    Why is life becoming so complicated as afterall most of us just want to plug in and get on with what we want to do.

    One thing, if a usb port is enabled but not in use how does that effect the battery performance.?
Sign In or Register to comment.

Who's Online in this Category0